summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-29 12:44:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-29 12:44:33 +0000
commit6c014f42be6af843735454861abf8dcaaa617b2f (patch)
tree0250724adca4f61d8563ea1068835d17f6744972 /dev-ruby
parentMarked ~x86-solaris (diff)
downloadgentoo-2-6c014f42be6af843735454861abf8dcaaa617b2f.tar.gz
gentoo-2-6c014f42be6af843735454861abf8dcaaa617b2f.tar.bz2
gentoo-2-6c014f42be6af843735454861abf8dcaaa617b2f.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.22.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index cb39a0d11d40..c0bfa92f98ec 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.61 2010/05/23 20:06:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.62 2010/05/29 12:44:33 flameeyes Exp $
+
+*tzinfo-0.3.22 (29 May 2010)
+
+ 29 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tzinfo-0.3.22.ebuild:
+ Version bump.
23 May 2010; Pacho Ramos <pacho@gentoo.org> tzinfo-0.3.16.ebuild:
stable amd64, bug 312963
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.22.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.22.ebuild
new file mode 100644
index 000000000000..69fe4bc373e0
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.22.ebuild,v 1.1 2010/05/29 12:44:33 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}