summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-29 01:14:56 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-29 01:14:56 +0000
commit0147187be81071b8956178e432aeb5ef1f2cf2f9 (patch)
treef81d1240ca6d06d8f8582399088e9dde7209e303 /dev-util
parentVersion bump and old version cleanup (diff)
downloadgentoo-2-0147187be81071b8956178e432aeb5ef1f2cf2f9.tar.gz
gentoo-2-0147187be81071b8956178e432aeb5ef1f2cf2f9.tar.bz2
gentoo-2-0147187be81071b8956178e432aeb5ef1f2cf2f9.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/strace-4.5.18.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 911915dda69e..e8f2cc31249b 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.120 2008/08/16 01:58:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.121 2008/08/29 01:14:56 vapier Exp $
+
+*strace-4.5.18 (29 Aug 2008)
+
+ 29 Aug 2008; Mike Frysinger <vapier@gentoo.org> +strace-4.5.18.ebuild:
+ Version bump.
*strace-4.5.17 (16 Aug 2008)
diff --git a/dev-util/strace/strace-4.5.18.ebuild b/dev-util/strace/strace-4.5.18.ebuild
new file mode 100644
index 000000000000..a17e0b9604d2
--- /dev/null
+++ b/dev-util/strace/strace-4.5.18.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.18.ebuild,v 1.1 2008/08/29 01:14:56 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static aio"
+
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #epatch "${FILESDIR}"/${PN}-4.5.11-fbsd.patch
+
+ epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
+}
+
+src_compile() {
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+
+ econf $(use_enable aio libaio) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}