summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-05 20:31:55 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-05 20:31:55 +0000
commit75d576feefe702194ae7246571b10809460063fa (patch)
tree862b4b50ace6d1dbb2e9cb5da928935d000644fa /dev-util
parentStable on amd64 wrt bug #350624 (diff)
downloadgentoo-2-75d576feefe702194ae7246571b10809460063fa.tar.gz
gentoo-2-75d576feefe702194ae7246571b10809460063fa.tar.bz2
gentoo-2-75d576feefe702194ae7246571b10809460063fa.zip
Revision bump including and using fixed patch to use system libbfd (bug #350738 by Rafał Mużyło). Remove old and drop 9999 since it's not really being tested neither maintained downstream.
(Portage version: 2.1.9.28/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-debugger/ChangeLog13
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch7
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.8.1-r1.ebuild (renamed from dev-util/mono-debugger/mono-debugger-2.8.1.ebuild)11
-rw-r--r--dev-util/mono-debugger/mono-debugger-9999.ebuild22
4 files changed, 21 insertions, 32 deletions
diff --git a/dev-util/mono-debugger/ChangeLog b/dev-util/mono-debugger/ChangeLog
index def053e37a85..b99752782659 100644
--- a/dev-util/mono-debugger/ChangeLog
+++ b/dev-util/mono-debugger/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/mono-debugger
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.43 2010/11/26 11:06:48 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.44 2011/01/05 20:31:55 pacho Exp $
+
+*mono-debugger-2.8.1-r1 (05 Jan 2011)
+
+ 05 Jan 2011; Pacho Ramos <pacho@gentoo.org> -mono-debugger-2.8.1.ebuild,
+ +mono-debugger-2.8.1-r1.ebuild, files/mono-debugger-2.8-system-bfd.patch,
+ -mono-debugger-9999.ebuild:
+ Revision bump including and using fixed patch to use system libbfd (bug
+ #350738 by Rafał Mużyło). Remove old and drop 9999 since it's not really
+ being tested neither maintained downstream.
*mono-debugger-2.8.1 (26 Nov 2010)
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
index 44804bd10747..3925606c1fde 100644
--- a/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
+++ b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
@@ -2,7 +2,7 @@ diff --git a/configure.in b/configure.in
index c643e64..402be56 100644
--- a/configure.in
+++ b/configure.in
-@@ -64,6 +64,18 @@ case "$host" in
+@@ -64,6 +64,19 @@ case "$host" in
esac
AC_MSG_RESULT(ok)
@@ -14,6 +14,7 @@ index c643e64..402be56 100644
+ AC_CHECK_HEADERS([bfd.h], [], [AC_MSG_ERROR([Missing bfd.h header])])
+ AC_CHECK_LIB([bfd], [bfd_init], [:], [AC_MSG_ERROR([Missing libbfd library])])
+ AC_CHECK_LIB([opcodes], [init_disassemble_info], [:], [AC_MSG_ERROR([Missing libopcodes library])])
++ AC_CHECK_MEMBERS([asection.rawsize], [], [], [[#include <bfd.h>]])
+ ])
+
+AM_CONDITIONAL([SYSTEM_LIBBFD], [test "x$with_system_libbfd" = "xyes"])
@@ -52,9 +53,9 @@ index dad57ab..8e7ac68 100644
@SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
+else
-+libmonodebuggerbfdglue_la_LIBADD =
++libmonodebuggerbfdglue_la_LIBADD = -lopcodes -lbfd
+
-+libmonodebuggerbfdglue_la_CPPFLAGS = -lopcodes -lbfd \
++libmonodebuggerbfdglue_la_CPPFLAGS = \
+ @SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
+
+endif
diff --git a/dev-util/mono-debugger/mono-debugger-2.8.1.ebuild b/dev-util/mono-debugger/mono-debugger-2.8.1-r1.ebuild
index ba2766903793..8d9e07dd82ac 100644
--- a/dev-util/mono-debugger/mono-debugger-2.8.1.ebuild
+++ b/dev-util/mono-debugger/mono-debugger-2.8.1-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.8.1.ebuild,v 1.1 2010/11/26 11:06:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.8.1-r1.ebuild,v 1.1 2011/01/05 20:31:55 pacho Exp $
# bah, tests fail. Needs to be fixed ...
RESTRICT="test"
-EAPI=2
-
-PATCHLEVEL=1
+EAPI="2"
inherit go-mono mono autotools flag-o-matic eutils
@@ -29,6 +27,8 @@ DEPEND="${RDEPEND}
src_prepare() {
go-mono_src_prepare
+
+ # Allow compilation against system libbfd, bnc#662581
epatch "${FILESDIR}/${PN}-2.8-system-bfd.patch"
eautoreconf
}
@@ -39,6 +39,7 @@ src_configure() {
append-ldflags -Wl,--no-undefined
go-mono_src_configure \
+ --with-system-libbfd \
--disable-static
}
diff --git a/dev-util/mono-debugger/mono-debugger-9999.ebuild b/dev-util/mono-debugger/mono-debugger-9999.ebuild
deleted file mode 100644
index 443bddc512d2..000000000000
--- a/dev-util/mono-debugger/mono-debugger-9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-9999.ebuild,v 1.3 2009/06/09 21:19:11 loki_val Exp $
-
-EAPI=2
-
-inherit go-mono mono
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="sys-libs/readline
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-RESTRICT="test"