summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-01 17:51:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-01 17:51:15 +0000
commitc64339b6cd74540b3bb97b77b372eb0482d59951 (patch)
tree4d765100db7ae20ba01cbeffe06c7e2aeefc6eab /dev-vcs/kdesvn
parentVersion bump to latest, remove older. (diff)
downloadgentoo-2-c64339b6cd74540b3bb97b77b372eb0482d59951.tar.gz
gentoo-2-c64339b6cd74540b3bb97b77b372eb0482d59951.tar.bz2
gentoo-2-c64339b6cd74540b3bb97b77b372eb0482d59951.zip
Version bump to release that kinda supports svn-1.7.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/kdesvn')
-rw-r--r--dev-vcs/kdesvn/ChangeLog7
-rw-r--r--dev-vcs/kdesvn/kdesvn-1.6.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-vcs/kdesvn/ChangeLog b/dev-vcs/kdesvn/ChangeLog
index 200f6fac703b..730959af31d1 100644
--- a/dev-vcs/kdesvn/ChangeLog
+++ b/dev-vcs/kdesvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/kdesvn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/kdesvn/ChangeLog,v 1.26 2012/08/04 14:36:35 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/kdesvn/ChangeLog,v 1.27 2012/09/01 17:51:15 scarabeus Exp $
+
+*kdesvn-1.6.0 (01 Sep 2012)
+
+ 01 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +kdesvn-1.6.0.ebuild:
+ Version bump to release that kinda supports svn-1.7.
04 Aug 2012; Johannes Huber <johu@gentoo.org> -kdesvn-1.5.5-r1.ebuild:
Remove old.
diff --git a/dev-vcs/kdesvn/kdesvn-1.6.0.ebuild b/dev-vcs/kdesvn/kdesvn-1.6.0.ebuild
new file mode 100644
index 000000000000..ff7566ce448d
--- /dev/null
+++ b/dev-vcs/kdesvn/kdesvn-1.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/kdesvn/kdesvn-1.6.0.ebuild,v 1.1 2012/09/01 17:51:15 scarabeus Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="cs de el es fr it ja lt pt_BR ro"
+KDE_LINGUAS_LIVE_OVERRIDE="true"
+KDE_SCM="svn"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDESvn is a frontend to the subversion vcs."
+HOMEPAGE="http://kdesvn.alwins-world.de/"
+if [[ ${PV} = 9999* ]]; then
+ ESVN_REPO_URI="http://www.alwins-world.de/repos/kdesvn/trunk/"
+ ESVN_PROJECT="kdesvn"
+else
+ SRC_URI="http://kdesvn.alwins-world.de/downloads/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/apr:1
+ dev-libs/apr-util:1
+ >=dev-vcs/subversion-1.4
+ sys-devel/gettext
+ x11-libs/qt-sql:4[sqlite]
+"
+RDEPEND="${DEPEND}"
+
+add_blocker "kdesdk-kioslaves[subversion(+)]"
+
+src_configure() {
+ append-cppflags -DQT_THREAD_SUPPORT
+
+ [[ ${PV} = 9999* ]] && mycmakeargs=(-DDAILY_BUILD=ON)
+
+ kde4-base_src_configure
+}