summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-31 04:54:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-31 04:54:18 +0000
commit13383621949d50653e27b0c2f38124519cf1b6b5 (patch)
treead973da14d3924dde43a1b4d4672f68ef52739d0 /games-action/luola
parentold (diff)
downloadgentoo-2-13383621949d50653e27b0c2f38124519cf1b6b5.tar.gz
gentoo-2-13383621949d50653e27b0c2f38124519cf1b6b5.tar.bz2
gentoo-2-13383621949d50653e27b0c2f38124519cf1b6b5.zip
fix install #110967 by Will Briggs
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/luola-1.3.0.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/games-action/luola/luola-1.3.0.ebuild b/games-action/luola/luola-1.3.0.ebuild
index 3b1640ac013d..fd3ce58a4231 100644
--- a/games-action/luola/luola-1.3.0.ebuild
+++ b/games-action/luola/luola-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0.ebuild,v 1.1 2005/10/24 20:16:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0.ebuild,v 1.2 2005/10/31 04:54:18 vapier Exp $
inherit eutils games
@@ -21,22 +21,18 @@ DEPEND="media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-ttf"
-src_unpack() {
- unpack ${A}
- mv "${WORKDIR}/README.Nostalgia" "${S}" || die "mv failed"
-}
-
src_compile() {
- egamesconf \
- --enable-sound || die
+ egamesconf --enable-sound || die
emake || die "emake failed"
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- insinto "${GAMES_DATADIR}/${PN}/levels"
- doins "${WORKDIR}/"*.{lev,png,jpg} || die "doins failed"
- dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README* TODO
+ insinto "${GAMES_DATADIR}"/${PN}/levels
+ doins "${WORKDIR}"/*.{lev,png} || die "doins failed"
+ dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
+ RELEASENOTES.txt ../README.Nostalgia
+ newdoc ../README README.stdlevels
doicon luola.png
make_desktop_entry luola Luola
prepgamesdirs