summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-06 22:03:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-06 22:03:22 +0000
commitbfe900a8750def6cfafeb07239accd7ef2890efa (patch)
treef093e6a5b816a3b4e57c0d06557979e43a793e4e /games-action
parentEAPI 5 (diff)
downloadgentoo-2-bfe900a8750def6cfafeb07239accd7ef2890efa.tar.gz
gentoo-2-bfe900a8750def6cfafeb07239accd7ef2890efa.tar.bz2
gentoo-2-bfe900a8750def6cfafeb07239accd7ef2890efa.zip
add patch from Martin Väth to build with newer toolchaing (bug #537336)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/ChangeLog8
-rw-r--r--games-action/gltron/files/gltron-0.70-gcc49.patch13
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild5
3 files changed, 23 insertions, 3 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index 7355c2b8e9de..8c303a001337 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/gltron
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.18 2015/01/10 19:46:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.19 2015/02/06 22:03:22 mr_bones_ Exp $
+
+ 06 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gltron-0.70-gcc49.patch, files/gltron-0.70-configure.patch,
+ files/gltron-0.70-debian.patch, files/gltron-0.70-prototypes.patch,
+ gltron-0.70-r1.ebuild:
+ add patch from Martin Väth to build with newer toolchaing (bug #537336)
10 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> gltron-0.70-r1.ebuild:
EAPI=5
diff --git a/games-action/gltron/files/gltron-0.70-gcc49.patch b/games-action/gltron/files/gltron-0.70-gcc49.patch
new file mode 100644
index 000000000000..4a1d5cbe1e1e
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-gcc49.patch
@@ -0,0 +1,13 @@
+--- 1/lua/src/lib/liolib.c
++++ 1/lua/src/lib/liolib.c
+@@ -6,9 +6,9 @@
+ */
+
+
++#define __USE_MISC /* for mkstemp() */
+ #include <ctype.h>
+ #include <stdio.h>
+-#define __USE_MISC /* for mkstemp() */
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index cae60888adb3..31418b62770b 100644
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.10 2015/01/10 19:46:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.11 2015/02/06 22:03:22 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -28,7 +28,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-configure.patch \
"${FILESDIR}"/${P}-prototypes.patch \
- "${FILESDIR}"/${P}-debian.patch
+ "${FILESDIR}"/${P}-debian.patch \
+ "${FILESDIR}"/${P}-gcc49.patch
sed -i \
-e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
Makefile.in || die