summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-07 07:50:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-07 07:50:57 +0000
commit30302123fd0d95ef2bf5a046ccdf8b0e2fd7fe17 (patch)
treed212e3be206f415fc2d33015d0274400c8efd171 /games-board
parentMove here from ruby-ng testbed, including two patches. Add additional patch f... (diff)
downloadgentoo-2-30302123fd0d95ef2bf5a046ccdf8b0e2fd7fe17.tar.gz
gentoo-2-30302123fd0d95ef2bf5a046ccdf8b0e2fd7fe17.tar.bz2
gentoo-2-30302123fd0d95ef2bf5a046ccdf8b0e2fd7fe17.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/ChangeLog10
-rw-r--r--games-board/mah-jong/mah-jong-1.10.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 81e9a83782ea..b45ba5988530 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/mah-jong
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.14 2008/06/25 19:19:20 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.15 2010/01/07 07:50:57 mr_bones_ Exp $
+
+*mah-jong-1.10 (07 Jan 2010)
+
+ 07 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +mah-jong-1.10.ebuild:
+ version bump
25 Jun 2008; nixnut <nixnut@gentoo.org> mah-jong-1.8.ebuild:
Stable on ppc wrt bug 229171
diff --git a/games-board/mah-jong/mah-jong-1.10.ebuild b/games-board/mah-jong/mah-jong-1.10.ebuild
new file mode 100644
index 000000000000..bf7bf13cb13a
--- /dev/null
+++ b/games-board/mah-jong/mah-jong-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.10.ebuild,v 1.1 2010/01/07 07:50:57 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+MY_P="mj-${PV}-src"
+DESCRIPTION="A networked Mah Jong program, together with a computer player"
+HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
+SRC_URI="http://mahjong.julianbradfield.org/Source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/^.TH/ s/1/6/' xmj.man \
+ || die "sed failed"
+ sed -i \
+ -e "/^DESTDIR =/ s:=.*:= ${D}:" \
+ -e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
+ -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ emake install install.man || die "emake install failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}
+ dodoc CHANGES ChangeLog *.txt
+ prepgamesdirs
+}