summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-07-14 19:29:04 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-07-14 19:29:04 +0000
commit405e8e6a31bc5654cd822653132ee8bd29c1f389 (patch)
treea8e98b01e7461d0148c79e4c1d15a8906c4fe198 /games-board
parentmarked x86 per bug 426420 (diff)
downloadgentoo-2-405e8e6a31bc5654cd822653132ee8bd29c1f389.tar.gz
gentoo-2-405e8e6a31bc5654cd822653132ee8bd29c1f389.tar.bz2
gentoo-2-405e8e6a31bc5654cd822653132ee8bd29c1f389.zip
underlinkg patch not needed anymore (fixes bug 426530), source only compiles on >=sys-devel/gcc-4.6 add check, dropped autotools eclass and eautoreconf
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/openyahtzee/ChangeLog7
-rw-r--r--games-board/openyahtzee/files/openyahtzee-1.9.1-underlink.patch8
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.1.ebuild19
3 files changed, 19 insertions, 15 deletions
diff --git a/games-board/openyahtzee/ChangeLog b/games-board/openyahtzee/ChangeLog
index 8dfe98a40ec1..3e96cdc632b1 100644
--- a/games-board/openyahtzee/ChangeLog
+++ b/games-board/openyahtzee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/openyahtzee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.14 2012/07/11 21:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.15 2012/07/14 19:29:04 hasufell Exp $
+
+ 14 Jul 2012; Julian Ospald <hasufell@gentoo.org> openyahtzee-1.9.1.ebuild,
+ -files/openyahtzee-1.9.1-underlink.patch:
+ underlinkg patch not needed anymore (fixes bug 426530), source only compiles
+ on >=sys-devel/gcc-4.6 add check, dropped autotools eclass and eautoreconf
*openyahtzee-1.9.1 (11 Jul 2012)
diff --git a/games-board/openyahtzee/files/openyahtzee-1.9.1-underlink.patch b/games-board/openyahtzee/files/openyahtzee-1.9.1-underlink.patch
deleted file mode 100644
index 9e49012d131a..000000000000
--- a/games-board/openyahtzee/files/openyahtzee-1.9.1-underlink.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/Makefile.am.old 2011-06-20 13:41:03.264848550 +0200
-+++ src/Makefile.am 2011-06-20 13:42:39.667245673 +0200
-@@ -42,4 +42,4 @@
- openyahtzee.rc
-
- AM_CXXFLAGS = @WX_CXXFLAGS@
--openyahtzee_LDFLAGS = @WX_LIBS@
-+openyahtzee_LDADD = @WX_LIBS@ -ldl
diff --git a/games-board/openyahtzee/openyahtzee-1.9.1.ebuild b/games-board/openyahtzee/openyahtzee-1.9.1.ebuild
index 18f68a0418fd..366fc8fe4a99 100644
--- a/games-board/openyahtzee/openyahtzee-1.9.1.ebuild
+++ b/games-board/openyahtzee/openyahtzee-1.9.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/openyahtzee-1.9.1.ebuild,v 1.1 2012/07/11 21:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/openyahtzee-1.9.1.ebuild,v 1.2 2012/07/14 19:29:04 hasufell Exp $
EAPI=2
WX_GTK_VER="2.8"
-inherit eutils autotools wxwidgets games
+inherit eutils wxwidgets toolchain-funcs versionator games
DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
HOMEPAGE="http://openyahtzee.sourceforge.net/"
@@ -15,11 +15,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="x11-libs/wxGTK:2.8[X]"
+DEPEND=">=sys-devel/gcc-4.6
+ x11-libs/wxGTK:2.8[X]"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-underlink.patch
- eautoreconf
+pkg_setup() {
+ local ver=4.6
+ local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+ if ! version_is_at_least ${ver} $(gcc-version); then
+ eerror ${msg}
+ die ${msg}
+ fi
+
+ games_pkg_setup
}
src_configure() {