summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-13 23:56:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-13 23:56:18 +0000
commit272f8091d13da063df53a11198a282b8f02673a7 (patch)
tree74731f00e09b73dacf1afb6e6bd4bce869586c91 /games-mud
parentVersion bump per bug #246515. Also introduces kde4 version. Fix slotting. (diff)
downloadgentoo-2-272f8091d13da063df53a11198a282b8f02673a7.tar.gz
gentoo-2-272f8091d13da063df53a11198a282b8f02673a7.tar.bz2
gentoo-2-272f8091d13da063df53a11198a282b8f02673a7.zip
Fix building with glibc-2.10, bug #273522
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/mcl/ChangeLog8
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch11
-rw-r--r--games-mud/mcl/mcl-0.53.00.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/games-mud/mcl/ChangeLog b/games-mud/mcl/ChangeLog
index ca3ca6743b95..be5629bd9c97 100644
--- a/games-mud/mcl/ChangeLog
+++ b/games-mud/mcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/mcl
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/ChangeLog,v 1.18 2008/11/30 08:05:44 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/ChangeLog,v 1.19 2009/06/13 23:56:18 nyhm Exp $
+
+ 13 Jun 2009; Tristan Heaven <nyhm@gentoo.org> mcl-0.53.00.ebuild,
+ +files/mcl-0.53.00-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273522
30 Nov 2008; Tupone Alfredo <tupone@gentoo.org>
-files/mcl-0.53.00-inputlines.patch, mcl-0.53.00.ebuild:
diff --git a/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch b/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch
new file mode 100644
index 000000000000..62bedb8b7c93
--- /dev/null
+++ b/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch
@@ -0,0 +1,11 @@
+--- plugins/PythonEmbeddedInterpreter.cc
++++ plugins/PythonEmbeddedInterpreter.cc
+@@ -132,7 +132,7 @@
+ bool PythonEmbeddedInterpreter::run_quietly(const char *file, const char *args,
+ char *result, bool suppress)
+ {
+- char *func = strrchr(file, '/');
++ char *func = strrchr((char *)file, '/');
+ char buf[256];
+
+ if(func) func++;
diff --git a/games-mud/mcl/mcl-0.53.00.ebuild b/games-mud/mcl/mcl-0.53.00.ebuild
index ddbcfac0ec39..94034fa07e72 100644
--- a/games-mud/mcl/mcl-0.53.00.ebuild
+++ b/games-mud/mcl/mcl-0.53.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.18 2008/11/30 08:05:44 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.19 2009/06/13 23:56:18 nyhm Exp $
inherit eutils games
@@ -28,7 +28,8 @@ src_unpack() {
"${FILESDIR}"/${PV}-dynacomplete.patch \
"${FILESDIR}"/${P}-libdir.patch \
"${WORKDIR}"/${P}-inputlines.patch \
- "${FILESDIR}"/${P}-gcc42.patch
+ "${FILESDIR}"/${P}-gcc42.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
sed -i \
-e "/MCL_LIBRARY_PATH/ s:/usr/lib/mcl:$(games_get_libdir)/${PN}:" \