summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-01 03:44:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-01 03:44:06 +0000
commit19494ae9b21e1c8f109c081244fc06c8ca6681f8 (patch)
treeee9126a81bb6daf8118831c2475c1a806d3dd7ca /games-sports/miniracer/miniracer-1.04.ebuild
parent. (diff)
downloadgentoo-2-19494ae9b21e1c8f109c081244fc06c8ca6681f8.tar.gz
gentoo-2-19494ae9b21e1c8f109c081244fc06c8ca6681f8.tar.bz2
gentoo-2-19494ae9b21e1c8f109c081244fc06c8ca6681f8.zip
initial commit - ebuild submitted by Matija Suklje via bug #93056
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-sports/miniracer/miniracer-1.04.ebuild')
-rw-r--r--games-sports/miniracer/miniracer-1.04.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-sports/miniracer/miniracer-1.04.ebuild b/games-sports/miniracer/miniracer-1.04.ebuild
new file mode 100644
index 000000000000..bad76e952444
--- /dev/null
+++ b/games-sports/miniracer/miniracer-1.04.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/miniracer/miniracer-1.04.ebuild,v 1.1 2005/06/01 03:44:06 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="an OpenGL car racing game, based on ID's famous Quake® engine"
+HOMEPAGE="http://miniracer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/x11
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^CC=/d' \
+ -e "s:\$(DESTDIR)/usr/bin:\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/INCLUDES/s:-I/usr/include/SDL:$(sdl-config --cflags):" \
+ -e "/CFLAGS/s:-O3 -march=i486 -ffast-math -fexpensive-optimizations:${CFLAGS}:" \
+ -e "/LDFLAGS/s:-lSDL -lSDL_mixer -lpthread:$(sdl-config --libs) -lSDL_mixer:" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc TODO README ChangeLog
+ prepgamesdirs
+}