summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-09-16 19:53:39 +0000
committerThomas Kahle <tomka@gentoo.org>2012-09-16 19:53:39 +0000
commit3da16a4428e2d0f62996b224fd303d6ba61c2df1 (patch)
treea176a5fe4be09636e7028b99c1267aac588398ca /games-strategy/freeorion
parentarm stable, bug #434334 (diff)
downloadgentoo-2-3da16a4428e2d0f62996b224fd303d6ba61c2df1.tar.gz
gentoo-2-3da16a4428e2d0f62996b224fd303d6ba61c2df1.tar.bz2
gentoo-2-3da16a4428e2d0f62996b224fd303d6ba61c2df1.zip
Fix bugs 434954, 434996. Thanks hasufell
(Portage version: 2.1.11.16/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/freeorion')
-rw-r--r--games-strategy/freeorion/ChangeLog8
-rw-r--r--games-strategy/freeorion/freeorion-0.4.2_pre20120910-r1.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
index 96bb9a0cb6df..7122895a12d1 100644
--- a/games-strategy/freeorion/ChangeLog
+++ b/games-strategy/freeorion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeorion
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.1 2012/09/11 16:01:06 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.2 2012/09/16 19:53:39 tomka Exp $
+
+*freeorion-0.4.2_pre20120910-r1 (16 Sep 2012)
+
+ 16 Sep 2012; Thomas Kahle <tomka@gentoo.org>
+ +freeorion-0.4.2_pre20120910-r1.ebuild:
+ Fix bugs 434954, 434996. Thanks hasufell
*freeorion-0.4.2_pre20120910 (11 Sep 2012)
diff --git a/games-strategy/freeorion/freeorion-0.4.2_pre20120910-r1.ebuild b/games-strategy/freeorion/freeorion-0.4.2_pre20120910-r1.ebuild
new file mode 100644
index 000000000000..94e1a1b7b8ea
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.2_pre20120910-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/freeorion-0.4.2_pre20120910-r1.ebuild,v 1.1 2012/09/16 19:53:39 tomka Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python games
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+SRC_URI="http://dev.gentoo.org/~tomka/files/FreeOrion-${PV}.tar.bz2"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cg"
+
+# Needs a dev-games/gigi from the freeorion source directory.
+# It's safest to use the same version.
+RDEPEND="
+ dev-games/gigi[ogre,ois]
+ dev-games/ogre[cg?,opengl]
+ >=dev-libs/boost-1.47[python]
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/libsdl[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/FreeOrion-${PV}/"
+CMAKE_USE_DIR="${S}"
+CMAKE_VERBOSE="1"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # set OGRE plugin-dir
+ sed \
+ -e "s:PluginFolder=.:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
+ -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+
+ if use cg ; then
+ # add cg ogre plugin to config
+ echo "Plugin=Plugin_CgProgramManager" \
+ >> "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRELEASE_COMPILE_FLAGS=""
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # data files
+ rm "${CMAKE_USE_DIR}"/default/COPYING || die
+ # get rid of .svn (remove from next snapshot!)
+ find "${CMAKE_USE_DIR}"default/ -depth -type d -name .svn \
+ -exec rm -rf '{}' \; || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${CMAKE_USE_DIR}"/default || die
+
+ # bin
+ dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die
+ newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} \
+ "${GAMES_BINDIR}/${PN}.bin --resource-dir ./default" \
+ "${GAMES_DATADIR}/${PN}"
+
+ # config
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins "${CMAKE_USE_DIR}"/{OISInput,ogre_plugins}.cfg || die
+ # game uses relative paths
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/ogre_plugins.cfg \
+ "${GAMES_DATADIR}"/${PN}/ogre_plugins.cfg || die
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/OISInput.cfg \
+ "${GAMES_DATADIR}"/${PN}/OISInput.cfg || die
+
+ # other
+ dodoc "${CMAKE_USE_DIR}"/changelog.txt || die
+ newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \
+ ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}