summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:42:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:42:44 +0000
commit8921992f53ae395810e10176f88994a96b10ae51 (patch)
tree02208a50c6ae1c818f6d914fea162312db74c26b /games-strategy/wesnoth
parentreplaced another patch by epatch (Manifest recommit) (diff)
downloadgentoo-2-8921992f53ae395810e10176f88994a96b10ae51.tar.gz
gentoo-2-8921992f53ae395810e10176f88994a96b10ae51.tar.bz2
gentoo-2-8921992f53ae395810e10176f88994a96b10ae51.zip
Work around for broken compile on ppc from Ernst Persson via bug #48326; tidy
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.3.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 37e5be8ddd49..f693dcbdbc16 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.20 2004/04/18 23:26:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.21 2004/04/21 06:42:44 mr_bones_ Exp $
+
+ 20 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.3.ebuild:
+ Work around for broken compile on ppc from Ernst Persson via bug #48326; tidy
*wesnoth-0.7.3 (18 Apr 2004)
diff --git a/games-strategy/wesnoth/wesnoth-0.7.3.ebuild b/games-strategy/wesnoth/wesnoth-0.7.3.ebuild
index 5bcd3033e455..d6d070455f9f 100644
--- a/games-strategy/wesnoth/wesnoth-0.7.3.ebuild
+++ b/games-strategy/wesnoth/wesnoth-0.7.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.3.ebuild,v 1.1 2004/04/18 23:26:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.3.ebuild,v 1.2 2004/04/21 06:42:44 mr_bones_ Exp $
-inherit games
+inherit flag-o-matic games
DESCRIPTION="A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org/"
@@ -21,13 +21,15 @@ DEPEND=">=media-libs/libsdl-1.2
virtual/x11"
src_compile() {
+ append-flags -fsigned-char
+
egamesconf \
--disable-dependency-tracking \
- `use_enable server` \
- `use_enable editor` \
- `use_enable tools` \
- `use_enable gnome` \
- `use_enable kde` \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
|| die
emake || die "emake failed"
}