summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-08-28 11:31:52 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-08-28 11:31:52 +0000
commit9c2dac7705b340ddf188b21b00aaf5701a5b1801 (patch)
treecb28b9aa3f0f23788d36d4188bdeea71066cdf96 /kde-base/pykde4
parentRemove USE=bash-completion, install the completion file unconditionally follo... (diff)
downloadgentoo-2-9c2dac7705b340ddf188b21b00aaf5701a5b1801.tar.gz
gentoo-2-9c2dac7705b340ddf188b21b00aaf5701a5b1801.tar.bz2
gentoo-2-9c2dac7705b340ddf188b21b00aaf5701a5b1801.zip
Rebase failing patch wrt bug #520952.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog6
-rw-r--r--kde-base/pykde4/files/pykde4-4.14.0-arm-sip.patch23
-rw-r--r--kde-base/pykde4/pykde4-4.14.0.ebuild4
3 files changed, 30 insertions, 3 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index d7d10ee69232..4178e4dd91bb 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.298 2014/08/20 16:02:41 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.299 2014/08/28 11:31:52 kensington Exp $
+
+ 28 Aug 2014; Michael Palimaka <kensington@gentoo.org>
+ +files/pykde4-4.14.0-arm-sip.patch, pykde4-4.14.0.ebuild:
+ Rebase failing patch wrt bug #520952.
*pykde4-4.14.0 (20 Aug 2014)
diff --git a/kde-base/pykde4/files/pykde4-4.14.0-arm-sip.patch b/kde-base/pykde4/files/pykde4-4.14.0-arm-sip.patch
new file mode 100644
index 000000000000..f6391a8ec714
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.14.0-arm-sip.patch
@@ -0,0 +1,23 @@
+See Gentoo bug #322351.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -99,6 +99,9 @@ include_directories(
+ ${KDEPIMLIBS_INCLUDE_DIRS}
+ )
+
++# Pull in ARM configuration options if needed
++STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
++
+ set(SIP_INCLUDES ${CMAKE_BINARY_DIR} ${PYQT4_SIP_DIR} sip)
+ set(SIP_CONCAT_PARTS 8)
+ if (WIN32)
+@@ -106,7 +109,7 @@ if (WIN32)
+ else ()
+ set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
+ endif ()
+-set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
++set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
+
+ set(SIP_FILES_INSTALL_DIR ${SHARE_INSTALL_PREFIX}/sip)
+
diff --git a/kde-base/pykde4/pykde4-4.14.0.ebuild b/kde-base/pykde4/pykde4-4.14.0.ebuild
index 97862cddbaa3..c794f3cf8435 100644
--- a/kde-base/pykde4/pykde4-4.14.0.ebuild
+++ b/kde-base/pykde4/pykde4-4.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.14.0.ebuild,v 1.1 2014/08/20 16:02:41 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.14.0.ebuild,v 1.2 2014/08/28 11:31:52 kensington Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
@@ -56,7 +56,7 @@ src_prepare() {
fi
# See bug 322351
- use arm && epatch "${FILESDIR}/${PN}-4.10.1-arm-sip.patch"
+ use arm && epatch "${FILESDIR}/${PN}-4.14.0-arm-sip.patch"
sed -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' \
-i kpythonpluginfactory/CMakeLists.txt || die