summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-19 15:37:14 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-19 15:37:14 +0000
commitf3157555c3aa1310b319c4146ed199f979358bdf (patch)
tree43923cc5b8b0873c81f03311dfc75e66d35322ba /kde-base/qtruby/qtruby-3.3.2-r1.ebuild
parentRestored accidentaly removed patchfile, without which the 3.3.1 ebuild didn't... (diff)
downloadgentoo-2-f3157555c3aa1310b319c4146ed199f979358bdf.tar.gz
gentoo-2-f3157555c3aa1310b319c4146ed199f979358bdf.tar.bz2
gentoo-2-f3157555c3aa1310b319c4146ed199f979358bdf.zip
dcopperl, dcoppython, qtruby and korundum are being unslotted (moved to SLOT 0) as per bug 80858
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/qtruby/qtruby-3.3.2-r1.ebuild')
-rw-r--r--kde-base/qtruby/qtruby-3.3.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/qtruby/qtruby-3.3.2-r1.ebuild b/kde-base/qtruby/qtruby-3.3.2-r1.ebuild
new file mode 100644
index 000000000000..706b6b345016
--- /dev/null
+++ b/kde-base/qtruby/qtruby-3.3.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-3.3.2-r1.ebuild,v 1.1 2005/02/19 15:35:45 danarmak Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt"
+KM_MAKEFILESREV=1
+MAXKDEVER=3.3.2
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Ruby bindings for QT"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="x86"
+IUSE=""
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/smoke-3.3.1"
+DEPEND=" >=virtual/ruby-1.8
+$(deprange 3.3.1 $PV kde-base/smoke)"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}