summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-04-04 08:31:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-04-04 08:31:12 +0000
commit9e8b14060bef14631ea2752c83d7f457d68182e9 (patch)
tree71da1bf7644a6b393b1a8ecd8015696bc8b1a4d0 /media-libs/libxtract
parentupdate homepage (diff)
downloadgentoo-2-9e8b14060bef14631ea2752c83d7f457d68182e9.tar.gz
gentoo-2-9e8b14060bef14631ea2752c83d7f457d68182e9.tar.bz2
gentoo-2-9e8b14060bef14631ea2752c83d7f457d68182e9.zip
convert to eapi5
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libxtract')
-rw-r--r--media-libs/libxtract/ChangeLog5
-rw-r--r--media-libs/libxtract/libxtract-0.6.3.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/media-libs/libxtract/ChangeLog b/media-libs/libxtract/ChangeLog
index 58cb4f1bdc40..b8cde4f80d66 100644
--- a/media-libs/libxtract/ChangeLog
+++ b/media-libs/libxtract/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libxtract
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libxtract/ChangeLog,v 1.10 2013/04/04 08:28:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libxtract/ChangeLog,v 1.11 2013/04/04 08:31:12 aballier Exp $
+
+ 04 Apr 2013; Alexis Ballier <aballier@gentoo.org> libxtract-0.6.3.ebuild:
+ convert to eapi5
04 Apr 2013; Alexis Ballier <aballier@gentoo.org> libxtract-0.4.7.ebuild,
libxtract-0.6.3.ebuild:
diff --git a/media-libs/libxtract/libxtract-0.6.3.ebuild b/media-libs/libxtract/libxtract-0.6.3.ebuild
index 8cdf827276a0..84e43e2d6d7d 100644
--- a/media-libs/libxtract/libxtract-0.6.3.ebuild
+++ b/media-libs/libxtract/libxtract-0.6.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libxtract/libxtract-0.6.3.ebuild,v 1.4 2013/04/04 08:28:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libxtract/libxtract-0.6.3.ebuild,v 1.5 2013/04/04 08:31:12 aballier Exp $
+
+EAPI=5
DESCRIPTION="A simple, portable, lightweight library of audio feature extraction functions"
HOMEPAGE="http://github.com/jamiebullock/LibXtract"
@@ -11,22 +13,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc fftw static-libs"
-RDEPEND="fftw? ( =sci-libs/fftw-3* )"
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_compile() {
+src_configure() {
econf \
$(use_enable fftw fft) \
$(use_enable static-libs static)
# Prevent doc from being generated automagically
use doc || touch doc/doxygen-build.stamp
- emake || die "make failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- find "${D}" -name "*.la" -delete
+ emake DESTDIR="${D}" install
+ find "${ED}" -name "*.la" -delete
dodoc README TODO AUTHORS
use doc && dohtml doc/html/*
}