summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-05-24 22:53:27 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-05-24 22:53:27 +0000
commit4609a366fc87936bb55505c9a4617e7fe927478d (patch)
tree7edfd50ac576cd9a4518cd1706bc85ed0719dc4c /media-libs/pdflib
parentdont install emacs crap when USE=-emacs (diff)
downloadgentoo-2-4609a366fc87936bb55505c9a4617e7fe927478d.tar.gz
gentoo-2-4609a366fc87936bb55505c9a4617e7fe927478d.tar.bz2
gentoo-2-4609a366fc87936bb55505c9a4617e7fe927478d.zip
Version bump; not my area, but approved by chriswhite.
Diffstat (limited to 'media-libs/pdflib')
-rw-r--r--media-libs/pdflib/ChangeLog7
-rw-r--r--media-libs/pdflib/files/digest-pdflib-6.0.11
-rw-r--r--media-libs/pdflib/pdflib-6.0.1.ebuild109
3 files changed, 116 insertions, 1 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index e57ab116f7e0..f44bdb833b95 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.54 2005/02/20 22:39:11 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.55 2005/05/24 22:53:27 spyderous Exp $
+
+*pdflib-6.0.1 (24 May 2005)
+
+ 24 May 2005; Donnie Berkholz <spyderous@gentoo.org>; +pdflib-6.0.1.ebuild:
+ Version bump; not my area, but approved by chriswhite.
20 Feb 2005; Hardave Riar <hardave@gentoo.org> pdflib-5.0.4_p1-r1.ebuild:
Stable on mips
diff --git a/media-libs/pdflib/files/digest-pdflib-6.0.1 b/media-libs/pdflib/files/digest-pdflib-6.0.1
new file mode 100644
index 000000000000..5439bdd0c685
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-6.0.1
@@ -0,0 +1 @@
+MD5 6a4f3c0c8407e0ed1d5c9d5233b1b62b PDFlib-Lite-6.0.1.tar.gz 3642803
diff --git a/media-libs/pdflib/pdflib-6.0.1.ebuild b/media-libs/pdflib/pdflib-6.0.1.ebuild
new file mode 100644
index 000000000000..82d2ce42b2b2
--- /dev/null
+++ b/media-libs/pdflib/pdflib-6.0.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-6.0.1.ebuild,v 1.1 2005/05/24 22:53:27 spyderous Exp $
+
+# eutils must be inherited since get_libdir() is only
+# globally available on baselayout-1.11 (still on ~arch)
+inherit eutils java-pkg
+
+MY_PN="${PN/pdf/PDF}-Lite"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A library for generating PDF on the fly"
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/products/pdflib/download/${PV//./}src/${MY_P}.tar.gz"
+
+LICENSE="Aladdin"
+SLOT="5"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~ppc-macos ~s390"
+IUSE="tcltk perl python java"
+
+DEPEND=">=sys-apps/sed-4
+ tcltk? ( >=dev-lang/tk-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3 )"
+
+src_compile() {
+ local myconf=
+
+ PYVER="$(/usr/bin/python -V 2>&1 | cut -d ' ' -f 2 | cut -d '.' -f 1,2)"
+ # Necessary for multilib on amd64. Please keep this in future releases.
+ # BUG #81197
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/02/14
+ TCLVER="$(echo 'puts [info tclversion]' | $(which tclsh))"
+ use tcltk \
+ && myconf="--with-tclpkg=/usr/$(get_libdir)/tcl${TCLVER}/" \
+ || myconf="--with-tcl=no"
+ use perl || myconf="${myconf} --with-perl=no"
+ use python \
+ && myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}" \
+ || myconf="${myconf} --with-py=no"
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ econf \
+ --enable-cxx \
+ ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ ${S}/bind/pdflib/perl/Makefile \
+ || die "sed bind/pdflib/perl/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ ${S}/bind/pdflib/python/Makefile \
+ || die "sed bind/pdflib/python/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ ${S}/bind/pdflib/tcl/Makefile \
+ || die "sed bind/pdflib/tcl/Makefile failed"
+
+ # ok, this should create the correct lib dirs for perl and python.
+ # yes, i know it is messy, but as i see it, a ebuild should be generic
+ # ... ie. you should be able to just use cp to update it
+ if use perl && [ -x /usr/bin/perl ] ; then
+ local perlmajver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4 |cut -d '.' -f 1`"
+ local perlver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4`"
+ local perlarch="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 7`"
+ dodir /usr/$(get_libdir)/perl${perlmajver/v/}/site_perl/${perlver/v/}/${perlarch}
+ fi
+ if use python && [ -x /usr/bin/python ] ; then
+ dodir /usr/$(get_libdir)/python${PYVER}/lib-dynload
+ fi
+ #next line required for proper install
+ dodir /usr/bin
+ einstall || die
+
+ dodoc readme.txt doc/*
+
+ # seemant: seems like the makefiles for pdflib generate the .jar file
+ # anyway
+ use java && java-pkg_dojar bind/pdflib/java/pdflib.jar
+
+ # karltk: This is definitely NOT how it should be done!
+ # we need this to create pdflib.jar (we will not have the source when
+ # this is a binary package ...)
+# if use java
+# then
+# insinto /usr/share/pdflib
+# doins ${S}/bind/pdflib/java/pdflib.java
+#
+# mkdir -p com/pdflib
+# mv ${S}/bind/pdflib/java/pdflib.java com/pdflib
+# javac com/pdflib/pdflib.java
+#
+# jar cf pdflib.jar com/pdflib/*.class
+#
+# java-pkg_dojar pdflib.jar
+# fi
+}