summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-03-16 21:01:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-03-16 21:01:44 +0000
commit88a70d1cefab1821bf27199ecb2697c02ca77521 (patch)
tree79ea9bdb01ecc93b4c64f1aab0311b6afe2a4c19 /media-libs/rubberband
parentBump (diff)
downloadgentoo-2-88a70d1cefab1821bf27199ecb2697c02ca77521.tar.gz
gentoo-2-88a70d1cefab1821bf27199ecb2697c02ca77521.tar.bz2
gentoo-2-88a70d1cefab1821bf27199ecb2697c02ca77521.zip
version bump
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/ChangeLog9
-rw-r--r--media-libs/rubberband/rubberband-1.3.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index 0462098dcfe4..df35745bc331 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/rubberband
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.6 2008/07/11 16:14:43 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.7 2009/03/16 21:01:44 aballier Exp $
+
+*rubberband-1.3 (16 Mar 2009)
+
+ 16 Mar 2009; Alexis Ballier <aballier@gentoo.org> +rubberband-1.3.ebuild:
+ version bump
*rubberband-1.2 (11 Jul 2008)
diff --git a/media-libs/rubberband/rubberband-1.3.ebuild b/media-libs/rubberband/rubberband-1.3.ebuild
new file mode 100644
index 000000000000..22f9bc61c33f
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.3.ebuild,v 1.1 2009/03/16 21:01:44 aballier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://www.breakfastquay.com/rubberband/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ =sci-libs/fftw-3*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install || die "make install failed"
+ dodoc README
+}