summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-15 11:05:59 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-15 11:05:59 +0000
commit911e7dc95d925f2eb81c86116533fbad494158c6 (patch)
tree79d55360c80baa836bce1fccd39f887cfb49039f /media-libs/rubberband
parentVersion Bump (diff)
downloadgentoo-2-911e7dc95d925f2eb81c86116533fbad494158c6.tar.gz
gentoo-2-911e7dc95d925f2eb81c86116533fbad494158c6.tar.bz2
gentoo-2-911e7dc95d925f2eb81c86116533fbad494158c6.zip
Version bump. Add static-libs use flag.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/ChangeLog9
-rw-r--r--media-libs/rubberband/rubberband-1.7.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index 79f54f90ed45..23f6648c5b4d 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/rubberband
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.14 2011/04/26 06:52:08 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.15 2012/02/15 11:05:59 radhermit Exp $
+
+*rubberband-1.7.0 (15 Feb 2012)
+
+ 15 Feb 2012; Tim Harder <radhermit@gentoo.org> +rubberband-1.7.0.ebuild:
+ Version bump. Add static-libs use flag.
26 Apr 2011; Tim Harder <radhermit@gentoo.org> rubberband-1.6.0.ebuild,
+files/rubberband-1.6.0-gcc-4.6.patch:
diff --git a/media-libs/rubberband/rubberband-1.7.0.ebuild b/media-libs/rubberband/rubberband-1.7.0.ebuild
new file mode 100644
index 000000000000..78ee46d918e2
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.7.0.ebuild,v 1.1 2012/02/15 11:05:59 radhermit Exp $
+
+EAPI=4
+inherit multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://code.breakfastquay.com/attachments/download/23/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ if ! use static-libs ; then
+ sed -i -e '/^all:/s/$(STATIC_TARGET)//' \
+ -e '/^\tcp $(STATIC_TARGET)/d' \
+ Makefile.in || die
+ fi
+}
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install
+
+ dodoc CHANGELOG README.txt
+}