summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-09 08:44:53 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-09 08:44:53 +0000
commit12728fc4dda34afce4c596287b079cfa40198409 (patch)
tree3605144119c172e3163a526931ff58bf84a36d90 /media-libs/taglib
parentDon't call gtk-doc configure option when not available (diff)
downloadgentoo-2-12728fc4dda34afce4c596287b079cfa40198409.tar.gz
gentoo-2-12728fc4dda34afce4c596287b079cfa40198409.tar.bz2
gentoo-2-12728fc4dda34afce4c596287b079cfa40198409.zip
Version bump.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/taglib')
-rw-r--r--media-libs/taglib/ChangeLog7
-rw-r--r--media-libs/taglib/taglib-1.7.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index f602e739badb..3a440a447af6 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.122 2012/05/05 08:02:42 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.123 2012/05/09 08:44:53 johu Exp $
+
+*taglib-1.7.2 (09 May 2012)
+
+ 09 May 2012; Johannes Huber <johu@gentoo.org> +taglib-1.7.2.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> taglib-1.7.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-libs/taglib/taglib-1.7.2.ebuild b/media-libs/taglib/taglib-1.7.2.ebuild
new file mode 100644
index 000000000000..57e7bd52d7a8
--- /dev/null
+++ b/media-libs/taglib/taglib-1.7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.7.2.ebuild,v 1.1 2012/05/09 08:44:53 johu Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="A library for reading and editing audio meta data"
+HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
+SRC_URI="http://developer.kde.org/~wheeler/files/src/${P}.tar.gz"
+
+LICENSE="LGPL-2 MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="+asf debug examples +mp4 test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install-examples.patch
+)
+
+DOCS="AUTHORS NEWS"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_with asf)
+ $(cmake-utils_use_with mp4)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use asf; then
+ elog "You've chosen to disable the asf use flag, thus taglib won't include"
+ elog "support for Microsoft's 'advanced systems format' media container"
+ fi
+ if ! use mp4; then
+ elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
+ elog "support for the MPEG-4 part 14 / MP4 media container"
+ fi
+}