summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2011-10-05 22:06:11 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2011-10-05 22:06:11 +0000
commitdac770a9bdcd0369f4b6319cc96b3714aae7e2cf (patch)
treedfc70944ad80ec10e9f68ab514747645c7131dee /media-libs/vigra
parentRaise mono-addins dep, bug #385383 by Anton Romanov. (diff)
downloadgentoo-2-dac770a9bdcd0369f4b6319cc96b3714aae7e2cf.tar.gz
gentoo-2-dac770a9bdcd0369f4b6319cc96b3714aae7e2cf.tar.bz2
gentoo-2-dac770a9bdcd0369f4b6319cc96b3714aae7e2cf.zip
Make API docs truly optional, bug 385645.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/ChangeLog7
-rw-r--r--media-libs/vigra/vigra-1.7.1-r1.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/media-libs/vigra/ChangeLog b/media-libs/vigra/ChangeLog
index c4c19b40a17f..ec7f5af564a5 100644
--- a/media-libs/vigra/ChangeLog
+++ b/media-libs/vigra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/vigra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.35 2011/10/04 21:37:51 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.36 2011/10/05 22:06:11 reavertm Exp $
+
+*vigra-1.7.1-r1 (05 Oct 2011)
+
+ 05 Oct 2011; Maciej Mrozowski <reavertm@gentoo.org> +vigra-1.7.1-r1.ebuild:
+ Make API docs truly optional, bug 385645.
04 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> vigra-1.7.1.ebuild:
x86 stable wrt bug #385217
diff --git a/media-libs/vigra/vigra-1.7.1-r1.ebuild b/media-libs/vigra/vigra-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..5c597c5d817f
--- /dev/null
+++ b/media-libs/vigra/vigra-1.7.1-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.7.1-r1.ebuild,v 1.1 2011/10/05 22:06:11 reavertm Exp $
+
+EAPI=4
+
+MY_P=${P}-src
+inherit base cmake-utils multilib
+
+DESCRIPTION="C++ computer vision library with emphasize on customizable algorithms and data structures"
+HOMEPAGE="http://hci.iwr.uni-heidelberg.de/vigra/"
+SRC_URI="http://hci.iwr.uni-heidelberg.de/vigra/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +fftw +hdf5 +jpeg +png +python test +tiff"
+
+RDEPEND="
+ dev-libs/boost
+ fftw? ( >=sci-libs/fftw-3 )
+ hdf5? ( sci-libs/hdf5 )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ python? (
+ || ( dev-lang/python:2.6 dev-lang/python:2.7 )
+ )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ python? ( dev-python/sphinx )
+ )
+ test? (
+ python? ( dev-python/nose )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.7.1-png-1.5.patch"
+ "${FILESDIR}/1.7.1-automagicness.patch"
+ "${FILESDIR}/1.7.1-hdf5.patch"
+ "${FILESDIR}/1.7.1-gcc4.6.patch"
+ "${FILESDIR}/1.7.1-numpy_doc.patch"
+ "${FILESDIR}/1.7.1-fix-tests.patch"
+ "${FILESDIR}/1.7.1-fix-nosetest.patch"
+)
+
+REQUIRED_USE="
+ doc? ( hdf5 fftw )
+ python? ( hdf5 )
+ test? ( hdf5 python fftw )
+"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+DOCS=(README.txt)
+
+src_prepare() {
+ base_src_prepare
+
+ # Don't build nor install API docs when not requested
+ use doc || sed -e '/ADD_SUBDIRECTORY(docsrc)/d' -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+
+ # required for ddocdir
+ _check_build_dir init
+ # vigranumpy needs python and if enabled it ooms
+ # doc needs doxygen and python
+ # walgrind no use for us since we restrict test
+ # $(cmake-utils_use_with valgrind VALGRIND)
+ local mycmakeargs=(
+ "-DDOCDIR=${CMAKE_BUILD_DIR}/doc"
+ "-DLIBDIR_SUFFIX=${libdir/lib}"
+ "-DDOCINSTALL=share/doc/${PF}"
+ "-DWITH_VALGRIND=OFF"
+ $(cmake-utils_use_with python VIGRANUMPY)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with tiff)
+ $(cmake-utils_use_with fftw FFTW3)
+ $(cmake-utils_use_with hdf5)
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use test CREATE_CTEST_TARGETS)
+ $(cmake-utils_use test AUTOBUILD_TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # drop useless cmake files from libdir
+ rm -rf "${ED}"/usr/$(get_libdir)/${PN}/
+}