summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-03 17:13:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-03 17:13:36 +0000
commitf0f37cd54a00a6a7914b2fa0a8fbd7b0f955c715 (patch)
tree43924e3ccc00b90925b0eff5caad1cc5a52d8587 /media-libs
parentStable on x86, bug 522314. Thanks to Poly-C for testing. (diff)
downloadgentoo-2-f0f37cd54a00a6a7914b2fa0a8fbd7b0f955c715.tar.gz
gentoo-2-f0f37cd54a00a6a7914b2fa0a8fbd7b0f955c715.tar.bz2
gentoo-2-f0f37cd54a00a6a7914b2fa0a8fbd7b0f955c715.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdc1394/ChangeLog7
-rw-r--r--media-libs/libdc1394/libdc1394-2.2.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/media-libs/libdc1394/ChangeLog b/media-libs/libdc1394/ChangeLog
index 278975b23c49..49fec3aba5bf 100644
--- a/media-libs/libdc1394/ChangeLog
+++ b/media-libs/libdc1394/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libdc1394
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.84 2014/08/10 09:30:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.85 2014/12/03 17:13:36 aballier Exp $
+
+*libdc1394-2.2.3 (03 Dec 2014)
+
+ 03 Dec 2014; Alexis Ballier <aballier@gentoo.org> +libdc1394-2.2.3.ebuild:
+ version bump
10 Aug 2014; Agostino Sarubbo <ago@gentoo.org> libdc1394-2.2.1.ebuild:
Stable for sparc, wrt bug #515234
diff --git a/media-libs/libdc1394/libdc1394-2.2.3.ebuild b/media-libs/libdc1394/libdc1394-2.2.3.ebuild
new file mode 100644
index 000000000000..f5de63de2155
--- /dev/null
+++ b/media-libs/libdc1394/libdc1394-2.2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/libdc1394-2.2.3.ebuild,v 1.1 2014/12/03 17:13:36 aballier Exp $
+
+EAPI=5
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Library to interface with IEEE 1394 cameras following the IIDC specification"
+HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/sdl.m4-20140620.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs X"
+
+RDEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/libusb-1-r1:1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.2.1-pthread.patch
+
+ AT_M4DIR=${WORKDIR}/aclocal eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf="$(use_enable doc doxygen-html)"
+ multilib_is_native_abi || myconf="--disable-doxygen-html --disable-examples"
+
+ # X is only useful for examples that are not installed.
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --program-suffix=2 \
+ --without-x \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && use doc && emake doc
+}
+
+multilib_src_install() {
+ default
+ multilib_is_native_abi && use doc && dohtml doc/html/*
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}