summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2008-03-24 09:55:01 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2008-03-24 09:55:01 +0000
commiteb8ca9744d00dafffdae319ddd2e9163f94f5529 (patch)
treed3aa2efba00cbcc534e252ea75fd2607ed0cb3a6 /media-plugins/vdr-atscepg
parentversion bump (diff)
downloadgentoo-2-eb8ca9744d00dafffdae319ddd2e9163f94f5529.tar.gz
gentoo-2-eb8ca9744d00dafffdae319ddd2e9163f94f5529.tar.bz2
gentoo-2-eb8ca9744d00dafffdae319ddd2e9163f94f5529.zip
initial ebuild, moved from overlay vdr-1.5
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins/vdr-atscepg')
-rw-r--r--media-plugins/vdr-atscepg/ChangeLog10
-rw-r--r--media-plugins/vdr-atscepg/Manifest4
-rw-r--r--media-plugins/vdr-atscepg/metadata.xml12
-rw-r--r--media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild33
4 files changed, 59 insertions, 0 deletions
diff --git a/media-plugins/vdr-atscepg/ChangeLog b/media-plugins/vdr-atscepg/ChangeLog
new file mode 100644
index 000000000000..218298fd4011
--- /dev/null
+++ b/media-plugins/vdr-atscepg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-plugins/vdr-atscepg
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/ChangeLog,v 1.1 2008/03/24 09:55:01 hd_brummy Exp $
+
+*vdr-atscepg-0.1.1 (24 Mar 2008)
+
+ 24 Mar 2008; Joerg Bornkessel <hd_brummy@gentoo.org> +metadata.xml,
+ +vdr-atscepg-0.1.1.ebuild:
+ initial ebuild, moved from overlay vdr-1.5
+
diff --git a/media-plugins/vdr-atscepg/Manifest b/media-plugins/vdr-atscepg/Manifest
new file mode 100644
index 000000000000..92e36bab587d
--- /dev/null
+++ b/media-plugins/vdr-atscepg/Manifest
@@ -0,0 +1,4 @@
+DIST vdr-atscepg-0.1.1.tgz 41330 RMD160 976fc9e8c29350cbed3865cab3c8e041041224ca SHA1 1fb3e1da9f4f1baea65753bd5e86efff3b7f8e70 SHA256 8e352f210f180667c0dd2039a88ae86d45b27e45a263f87f143dfa9207e671bb
+EBUILD vdr-atscepg-0.1.1.ebuild 717 RMD160 d292439459f5a6e51ae38450938be0c629529d50 SHA1 aace3d70cde542d2c1d973ee7daa4d30db9e5eee SHA256 f5a73111069593e0cdb820bf000b0195430e574c7b9c6d8c1057577b9c5b9192
+MISC ChangeLog 305 RMD160 47a626a289ce15a4ae7488eb153fa3e45ddbfc49 SHA1 eb97d1d943d820a4790357c2423174ad87f0e1bd SHA256 c45c3b90a9f1f3917a521bd2370cc781a0fa9e7d5c1d640103aaaa3f854b1f5c
+MISC metadata.xml 298 RMD160 7e0a2f2a14c259d83aeca27b96f53bde893cc3cf SHA1 909d564739e5ee061ef40e6b09c6a48c6578269f SHA256 50a4a1a273a8415774ef522ac281cd664bd217c04bcbfa16e13b53649b9a9581
diff --git a/media-plugins/vdr-atscepg/metadata.xml b/media-plugins/vdr-atscepg/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-atscepg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
new file mode 100644
index 000000000000..54c09c4c0215
--- /dev/null
+++ b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild,v 1.1 2008/03/24 09:55:01 hd_brummy Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: implements the Program and System Information
+Protocol for DVB-T and DVB-C Broadcast from the ATSC standard"
+HOMEPAGE="http://www.fepg.org/atscepg.html"
+SRC_URI="http://www.fepg.org/files/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6"
+
+pkg_setup() {
+
+ if ! built_with_use media-video/vdr atsc; then
+ echo
+ ewarn "To support this plugin you need to"
+ ewarn "recompile media-video/vdr with use-flag atsc"
+ echo
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ fix_vdr_libsi_include tables.cpp
+}