summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-17 19:57:45 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-17 19:57:45 +0000
commit6161bdcb7432aed0510d440ae5b938ff6af0854c (patch)
treecab8f6097b205088081e49797e7a52d68af54a5b /media-plugins/vdr-markad
parentfix use_enable to remove things which are not ready yet (diff)
downloadgentoo-2-6161bdcb7432aed0510d440ae5b938ff6af0854c.tar.gz
gentoo-2-6161bdcb7432aed0510d440ae5b938ff6af0854c.tar.bz2
gentoo-2-6161bdcb7432aed0510d440ae5b938ff6af0854c.zip
Fix build with libav9. Fixes bug#443244.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'media-plugins/vdr-markad')
-rw-r--r--media-plugins/vdr-markad/ChangeLog9
-rw-r--r--media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch40
-rw-r--r--media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild5
3 files changed, 49 insertions, 5 deletions
diff --git a/media-plugins/vdr-markad/ChangeLog b/media-plugins/vdr-markad/ChangeLog
index fcd98bdcb409..b43ced07e525 100644
--- a/media-plugins/vdr-markad/ChangeLog
+++ b/media-plugins/vdr-markad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-markad
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-markad/ChangeLog,v 1.11 2012/09/27 19:28:37 hd_brummy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-markad/ChangeLog,v 1.12 2013/06/17 19:57:45 scarabeus Exp $
+
+ 17 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/vdr-markad-0.1.4-libav9.patch, vdr-markad-0.1.4.ebuild:
+ Fix build with libav9. Fixes bug#443244.
*vdr-markad-0.1.4 (27 Sep 2012)
@@ -64,4 +68,3 @@
25 Jan 2011; Joerg Bornkessel <hd_brummy@gentoo.org>
+vdr-markad-0.0.8.ebuild, +metadata.xml:
initial ebuild
-
diff --git a/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch b/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch
new file mode 100644
index 000000000000..fca9cbb49e35
--- /dev/null
+++ b/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch
@@ -0,0 +1,40 @@
+diff -urN markad-0.1.4.old/command/decoder.cpp markad-0.1.4/command/decoder.cpp
+--- markad-0.1.4.old/command/decoder.cpp 2013-06-17 21:52:44.333367552 +0200
++++ markad-0.1.4/command/decoder.cpp 2013-06-17 21:53:03.708366863 +0200
+@@ -11,6 +11,7 @@
+ #include <sys/types.h>
+ #include <string.h>
+ #include <cstdlib>
++#include <stdio.h>
+
+ #include "decoder.h"
+
+@@ -172,7 +173,7 @@
+
+ if (video_codec)
+ {
+- video_context = avcodec_alloc_context();
++ video_context = avcodec_alloc_context3(NULL);
+ if (video_context)
+ {
+ if (video_codec->capabilities & CODEC_CAP_TRUNCATED)
+@@ -321,7 +322,7 @@
+ {
+ avcodec_flush_buffers(video_context);
+ AVCodecContext *dest;
+- dest=avcodec_alloc_context();
++ dest=avcodec_alloc_context3(NULL);
+ if (dest)
+ {
+ if (avcodec_copy_context(dest,video_context)!=0) ret=false;
+diff -urN markad-0.1.4.old/command/decoder.h markad-0.1.4/command/decoder.h
+--- markad-0.1.4.old/command/decoder.h 2013-06-17 21:52:44.333367552 +0200
++++ markad-0.1.4/command/decoder.h 2013-06-17 21:53:03.708366863 +0200
+@@ -18,6 +18,7 @@
+ #include <avcodec.h>
+ #else
+ #include <libavcodec/avcodec.h>
++#include <libavutil/mem.h>
+ #endif
+
+ #if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
diff --git a/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild b/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild
index bdd8dd3e238c..82d609cba381 100644
--- a/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild
+++ b/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild,v 1.1 2012/09/27 19:28:37 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild,v 1.2 2013/06/17 19:57:45 scarabeus Exp $
EAPI="4"
@@ -32,6 +32,7 @@ src_prepare() {
vdr-plugin-2_src_prepare
cd "${S2}"
+ epatch "${FILESDIR}/${PN}-0.1.4-libav9.patch"
sed -i Makefile \
-e "s:\$(CXXFLAGS) \$(OBJS):\$(CXXFLAGS) \$(LDFLAGS) \$(OBJS):" \
-e "s:\@\$(STRIP) \$(DESTDIR)/usr/bin/markad::"