summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-15 22:34:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-15 22:34:48 +0000
commit44d0e502c3c3213a63926ec4fc5c40de2a31d304 (patch)
tree1650be53c5636144f8eff4c74c3304de957a622c /media-sound/ardour
parentRestrict compiler to javac which unlike ecj doesn't mind the API changes in 1.5+ (diff)
downloadgentoo-2-44d0e502c3c3213a63926ec4fc5c40de2a31d304.tar.gz
gentoo-2-44d0e502c3c3213a63926ec4fc5c40de2a31d304.tar.bz2
gentoo-2-44d0e502c3c3213a63926ec4fc5c40de2a31d304.zip
vesion bump
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog9
-rw-r--r--media-sound/ardour/ardour-2.2.ebuild117
-rw-r--r--media-sound/ardour/files/digest-ardour-2.23
3 files changed, 127 insertions, 2 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index 6fe2ed20bb01..dd4ad6709295 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ardour
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.65 2007/10/16 16:17:49 eldad Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.66 2008/01/15 22:34:47 aballier Exp $
+
+*ardour-2.2 (15 Jan 2008)
+
+ 15 Jan 2008; Alexis Ballier <aballier@gentoo.org> +ardour-2.2.ebuild:
+ vesion bump
*ardour-2.1 (16 Oct 2007)
diff --git a/media-sound/ardour/ardour-2.2.ebuild b/media-sound/ardour/ardour-2.2.ebuild
new file mode 100644
index 000000000000..831961aaa5e5
--- /dev/null
+++ b/media-sound/ardour/ardour-2.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.2.ebuild,v 1.1 2008/01/15 22:34:47 aballier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="multi-track hard disk recording software"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="http://ardour.org/files/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="altivec debug nls sse"
+
+RDEPEND="media-libs/liblo
+ >=media-libs/liblrdf-0.4.0
+ >=media-libs/raptor-1.4.2
+ >=media-sound/jack-audio-connection-kit-0.101.1
+ >=dev-libs/glib-2.10.3
+ x11-libs/pango
+ >=x11-libs/gtk+-2.8.8
+ media-libs/flac
+ media-libs/alsa-lib
+ >=media-libs/libsamplerate-0.1.1-r1
+ >=dev-libs/libxml2-2.6.0
+ dev-libs/libxslt
+ >=media-libs/libsndfile-1.0.16
+ gnome-base/libgnomecanvas
+ x11-themes/gtk-engines
+ >=dev-cpp/gtkmm-2.10
+ dev-cpp/glibmm
+ >=dev-cpp/libgnomecanvasmm-2.10.0
+ dev-cpp/cairomm
+ >=dev-libs/libsigc++-2.0
+ media-libs/libsoundtouch
+ dev-libs/libusb
+ =sci-libs/fftw-3*"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ dev-libs/boost
+ dev-util/pkgconfig
+ >=dev-util/scons-0.96.1
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if ! built_with_use dev-cpp/gtkmm accessibility; then
+ eerror "dev-cpp/gtkmm needs to be built with use accessibility"
+ eerror "in order to build ${PN}"
+ die "gtkmm was not built with use accessibility"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-2.0.3-sndfile-external.patch"
+ epatch "${FILESDIR}/${PN}-2.0.3-cflags.patch"
+}
+
+ardour_use_enable() {
+ use ${2} && echo "${1}=1" || echo "${1}=0"
+}
+
+src_compile() {
+ # Required for scons to "see" intermediate install location
+ mkdir -p "${D}"
+
+ local FPU_OPTIMIZATION=$((use altivec || use sse) && echo 1 || echo 0)
+ cd "${S}"
+
+ tc-export CC CXX
+
+ # Avoid compiling x86 asm when building on amd64 without using sse
+ # bug #186798
+ use amd64 && append-flags "-DUSE_X86_64_ASM"
+
+ scons \
+ $(ardour_use_enable DEBUG debug) \
+ FPU_OPTIMIZATION=${FPU_OPTIMIZATION} \
+ DESTDIR="${D}" \
+ $(ardour_use_enable NLS nls) \
+ FFT_ANALYSIS=1 \
+ SYSLIBS=1 \
+ CFLAGS="${CFLAGS}" \
+ PREFIX=/usr || die "scons make failed"
+}
+
+src_install() {
+ scons install || die "make install failed"
+
+ dodoc DOCUMENTATION/*
+
+ doicon "${S}/icons/icon/ardour_icon_mac.png"
+ make_desktop_entry ardour2 Ardour2 ardour_icon_mac.png AudioVideo
+}
+
+pkg_postinst() {
+ ewarn "---------------- WARNING -------------------"
+ ewarn ""
+ ewarn "Do not use Ardour 2.0 to open the only copy of sessions created with Ardour 0.99."
+ ewarn "Ardour 2.0 saves the session file in a new format that Ardour 0.99 will"
+ ewarn "not understand."
+ ewarn ""
+ ewarn "MAKE BACKUPS OF THE SESSION FILES."
+ ewarn ""
+ ewarn "The simplest way to address this is to make a copy of the session file itself"
+ ewarn "(e.g mysession/mysession.ardour) and make that file unreadable using chmod(1)."
+ ewarn ""
+ ewarn "---------------- WARNING -------------------"
+ ewarn ""
+ ewarn "If you use KDE 3.5, be sure to uncheck 'Apply colors to non-KDE applications' in"
+ ewarn "the colors configuration module if you want to be able to actually see various"
+ ewarn "texts in Ardour 2."
+}
diff --git a/media-sound/ardour/files/digest-ardour-2.2 b/media-sound/ardour/files/digest-ardour-2.2
new file mode 100644
index 000000000000..d0d49546431b
--- /dev/null
+++ b/media-sound/ardour/files/digest-ardour-2.2
@@ -0,0 +1,3 @@
+MD5 151dcc194dfdba3cd7f61faeed6e06f5 ardour-2.2.tar.bz2 4296980
+RMD160 ec1e00a546b51e3f8fd8afb0b6d661df66862cd1 ardour-2.2.tar.bz2 4296980
+SHA256 fc0d405e1e1d31b3e353095db67b7dc874c201ff43954751b72f57ae836799ee ardour-2.2.tar.bz2 4296980