summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-29 11:46:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-29 11:46:59 +0000
commit01a7ca3ab41c5b7c16893f63a44b982a737f2cd1 (patch)
treee8aaa48c2ce3047dfc6071d8acad2be44f68123a /media-sound
parentMove glx-define-prototype.patch and libpng14.patch to patchset tarball. (diff)
downloadgentoo-2-01a7ca3ab41c5b7c16893f63a44b982a737f2cd1.tar.gz
gentoo-2-01a7ca3ab41c5b7c16893f63a44b982a737f2cd1.tar.bz2
gentoo-2-01a7ca3ab41c5b7c16893f63a44b982a737f2cd1.zip
Fix building with USE="-mad" wrt #317595 by Sergiy Borodych.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/ChangeLog6
-rw-r--r--media-sound/sox/files/sox-14.3.1-nomad.patch15
-rw-r--r--media-sound/sox/sox-14.3.1.ebuild22
3 files changed, 34 insertions, 9 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 908abfd661b6..2b40d7f72966 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.118 2010/04/23 12:18:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.119 2010/04/29 11:46:59 ssuominen Exp $
+
+ 29 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> sox-14.3.1.ebuild,
+ +files/sox-14.3.1-nomad.patch:
+ Fix building with USE="-mad" wrt #317595 by Sergiy Borodych.
*sox-14.3.1 (23 Apr 2010)
diff --git a/media-sound/sox/files/sox-14.3.1-nomad.patch b/media-sound/sox/files/sox-14.3.1-nomad.patch
new file mode 100644
index 000000000000..7bcad4f4390d
--- /dev/null
+++ b/media-sound/sox/files/sox-14.3.1-nomad.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/317595
+
+--- src/mp3.c
++++ src/mp3.c
+@@ -56,8 +56,10 @@
+ * Sidestep the issue by defining our own mad_timer_zero. This is needed because
+ * mad_timer_zero is used in some of the mad.h macros.
+ */
++#ifdef HAVE_MAD_H
+ #define mad_timer_zero mad_timer_zero_stub
+ static mad_timer_t const mad_timer_zero_stub = {0, 0};
++#endif
+
+ #define MAXFRAMESIZE 2880
+ #define ID3PADDING 128
diff --git a/media-sound/sox/sox-14.3.1.ebuild b/media-sound/sox/sox-14.3.1.ebuild
index f64fb6c46918..a9bd8b6e26b8 100644
--- a/media-sound/sox/sox-14.3.1.ebuild
+++ b/media-sound/sox/sox-14.3.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.1 2010/04/23 12:18:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.2 2010/04/29 11:46:59 ssuominen Exp $
-inherit flag-o-matic
+EAPI=2
+inherit eutils flag-o-matic
DESCRIPTION="The swiss army knife of sound processing programs"
HOMEPAGE="http://sox.sourceforge.net"
@@ -13,7 +14,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg oss png pulseaudio sndfile wavpack"
-RDEPEND="alsa? ( media-libs/alsa-lib )
+# libtool required for libltdl
+RDEPEND="sys-devel/libtool
+ alsa? ( media-libs/alsa-lib )
amr? ( media-libs/opencore-amr )
encode? ( media-sound/lame )
flac? ( media-libs/flac )
@@ -31,11 +34,16 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile () {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nomad.patch
+}
+
+src_configure() {
# Fixes wav segfaults. See Bug #35745.
append-flags -fsigned-char
- econf $(use_with alsa) \
+ econf \
+ $(use_with alsa) \
$(use_enable debug) \
$(use_with ao) \
$(use_with oss) \
@@ -53,11 +61,9 @@ src_compile () {
$(use_with pulseaudio) \
$(use_with wavpack) \
--with-distro="Gentoo"
-
- emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die
dodoc NEWS ChangeLog README AUTHORS
}