summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-07-03 16:22:25 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-07-03 16:22:25 +0000
commitf3f1e23b96a4b70ea9930a8fd6a63ecedf39e2b5 (patch)
treeb0a4c1d4d6ea7ec725b403505876d8fc88ba9411 /media-tv/ivtv
parentInitial entry, for bug 163724. (diff)
downloadgentoo-2-f3f1e23b96a4b70ea9930a8fd6a63ecedf39e2b5.tar.gz
gentoo-2-f3f1e23b96a4b70ea9930a8fd6a63ecedf39e2b5.tar.bz2
gentoo-2-f3f1e23b96a4b70ea9930a8fd6a63ecedf39e2b5.zip
fix the includes for the linux/ivtv.h header
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog9
-rw-r--r--media-tv/ivtv/files/ivtv-1.1.0-headers.patch36
-rw-r--r--media-tv/ivtv/ivtv-1.1.0-r1.ebuild (renamed from media-tv/ivtv/ivtv-1.1.0.ebuild)10
3 files changed, 53 insertions, 2 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 87424f92f330..181fe3ccfda6 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.105 2008/06/30 19:38:41 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.106 2008/07/03 16:22:24 cardoe Exp $
+
+*ivtv-1.1.0-r1 (03 Jul 2008)
+
+ 03 Jul 2008; Doug Goldstein <cardoe@gentoo.org>
+ +files/ivtv-1.1.0-headers.patch, -ivtv-1.1.0.ebuild,
+ +ivtv-1.1.0-r1.ebuild:
+ fix the includes for the linux/ivtv.h header
30 Jun 2008; Doug Goldstein <cardoe@gentoo.org>
+files/ivtv-1.2.0-v4l2-dbg-include.patch, ivtv-1.2.0.ebuild:
diff --git a/media-tv/ivtv/files/ivtv-1.1.0-headers.patch b/media-tv/ivtv/files/ivtv-1.1.0-headers.patch
new file mode 100644
index 000000000000..c03088cfb27b
--- /dev/null
+++ b/media-tv/ivtv/files/ivtv-1.1.0-headers.patch
@@ -0,0 +1,36 @@
+diff -Nur ivtv-1.1.0/utils/ivtvctl.c ivtv-1.1.0-headers/utils/ivtvctl.c
+--- ivtv-1.1.0/utils/ivtvctl.c 2008-05-24 08:21:16.000000000 -0400
++++ ivtv-1.1.0-headers/utils/ivtvctl.c 2008-07-03 12:11:38.000000000 -0400
+@@ -63,7 +63,7 @@
+
+ #define VIDIOC_INT_RESET _IOW ('d', 102, __u32)
+
+-#include <linux/ivtv.h>
++#include "linux/ivtv.h"
+
+ #define __stringify_1(x) #x
+ #define __stringify(x) __stringify_1(x)
+diff -Nur ivtv-1.1.0/utils/ivtvplay.cc ivtv-1.1.0-headers/utils/ivtvplay.cc
+--- ivtv-1.1.0/utils/ivtvplay.cc 2008-05-24 08:21:16.000000000 -0400
++++ ivtv-1.1.0-headers/utils/ivtvplay.cc 2008-07-03 12:10:43.000000000 -0400
+@@ -41,7 +41,7 @@
+ #include <linux/types.h>
+ #include <linux/videodev2.h>
+ #include <linux/dvb/video.h>
+-#include <linux/ivtv.h>
++#include "linux/ivtv.h"
+
+ typedef unsigned long W32;
+ typedef unsigned long long W64;
+diff -Nur ivtv-1.1.0/utils/ivtv-radio.c ivtv-1.1.0-headers/utils/ivtv-radio.c
+--- ivtv-1.1.0/utils/ivtv-radio.c 2008-05-24 08:21:16.000000000 -0400
++++ ivtv-1.1.0-headers/utils/ivtv-radio.c 2008-07-03 12:10:08.000000000 -0400
+@@ -39,7 +39,7 @@
+
+ #include <linux/videodev2.h>
+ #include <linux/dvb/video.h>
+-#include <linux/ivtv.h>
++#include "linux/ivtv.h"
+
+ #define RADIO_DEV "/dev/radio0"
+ #define AUDIO_IN_DEV "/dev/video24"
diff --git a/media-tv/ivtv/ivtv-1.1.0.ebuild b/media-tv/ivtv/ivtv-1.1.0-r1.ebuild
index f60aa99b363f..84320503d903 100644
--- a/media-tv/ivtv/ivtv-1.1.0.ebuild
+++ b/media-tv/ivtv/ivtv-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.1.0.ebuild,v 1.1 2008/06/27 16:40:21 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.1.0-r1.ebuild,v 1.1 2008/07/03 16:22:24 cardoe Exp $
inherit eutils linux-mod
@@ -52,6 +52,14 @@ pkg_setup() {
BUILD_PARAMS="KDIR=${KV_DIR}"
}
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
src_compile() {
linux-mod_src_compile || die "failed to build driver"