summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-02 14:08:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-02 14:08:52 +0000
commit424aaf72ae9d32f4e6e380ab11bc1ca2d0dbc310 (patch)
tree2d9a60d7661f7c35bb62f378ab54aa200d8d597a /media-video
parentStable for HPPA (bug #389125). (diff)
downloadgentoo-2-424aaf72ae9d32f4e6e380ab11bc1ca2d0dbc310.tar.gz
gentoo-2-424aaf72ae9d32f4e6e380ab11bc1ca2d0dbc310.tar.bz2
gentoo-2-424aaf72ae9d32f4e6e380ab11bc1ca2d0dbc310.zip
add pulseaudio useflag
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index e702bf0b67fa..aa4aa51c0dc5 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.476 2011/11/01 00:37:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.477 2011/11/02 14:08:52 aballier Exp $
+
+ 02 Nov 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ add pulseaudio useflag
01 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> ffmpeg-0.7.6.ebuild,
ffmpeg-0.8.5.ebuild, ffmpeg-9999.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 736a69189301..dd2f39c1e23b 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.58 2011/11/01 00:37:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.59 2011/11/02 14:08:52 aballier Exp $
EAPI="4"
@@ -31,9 +31,9 @@ fi
IUSE="
aac aacplus alsa amr bindist +bzip2 cdio celt cpudetection debug dirac doc
+encode faac frei0r gsm +hardcoded-tables ieee1394 jack jpeg2k modplug mp3
- network openal oss pic qt-faststart rtmp schroedinger sdl speex static-libs
- test theora threads truetype v4l vaapi vdpau vorbis vpx X x264 xvid
- +zlib
+ network openal oss pic pulseaudio qt-faststart rtmp schroedinger sdl speex
+ static-libs test theora threads truetype v4l vaapi vdpau vorbis vpx X x264
+ xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -69,6 +69,7 @@ RDEPEND="
jpeg2k? ( >=media-libs/openjpeg-1.3-r2 )
modplug? ( media-libs/libmodplug )
openal? ( >=media-libs/openal-1.1 )
+ pulseaudio? ( media-sound/pulseaudio )
rtmp? ( >=media-video/rtmpdump-2.2f )
sdl? ( >=media-libs/libsdl-1.2.13-r1[audio,video] )
schroedinger? ( media-libs/schroedinger )
@@ -146,6 +147,7 @@ src_configure() {
use ${i} || myconf="${myconf} --disable-indev=${i}"
done
use X && myconf="${myconf} --enable-x11grab"
+ use pulseaudio && myconf="${myconf} --enable-libpulse"
# Outdevs
for i in alsa oss ; do
use ${i} || myconf="${myconf} --disable-outdev=${i}"