summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-05 20:20:50 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-05 20:20:50 +0000
commitfddaf5ada35f5532064163876a12b8a22ef34162 (patch)
tree2a8f75f138330a0e0a44ab3c179e3d8022210806 /net-analyzer/bmon
parentUse the latest autotools from the autotools eclass #191410. (diff)
downloadgentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.tar.gz
gentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.tar.bz2
gentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.zip
Fix for bug #176378
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-analyzer/bmon')
-rw-r--r--net-analyzer/bmon/ChangeLog8
-rw-r--r--net-analyzer/bmon/bmon-2.1.0-r3.ebuild43
-rw-r--r--net-analyzer/bmon/files/bmon-2.1.0-libnl-1.0.patch23
-rw-r--r--net-analyzer/bmon/files/digest-bmon-2.1.0-r33
4 files changed, 76 insertions, 1 deletions
diff --git a/net-analyzer/bmon/ChangeLog b/net-analyzer/bmon/ChangeLog
index 4f8c86f71500..66327662c4f6 100644
--- a/net-analyzer/bmon/ChangeLog
+++ b/net-analyzer/bmon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/bmon
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.32 2007/02/01 21:29:46 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.33 2007/09/05 20:20:50 jokey Exp $
+
+*bmon-2.1.0-r3 (05 Sep 2007)
+
+ 05 Sep 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/bmon-2.1.0-libnl-1.0.patch, +bmon-2.1.0-r3.ebuild:
+ Fix for bug #176378
01 Feb 2007; Markus Ullmann <jokey@gentoo.org>
+files/bmon-2.1.0-nostrip.patch, -files/bmon-nostrip.patch,
diff --git a/net-analyzer/bmon/bmon-2.1.0-r3.ebuild b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..d55926e3c4f9
--- /dev/null
+++ b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r3.ebuild,v 1.1 2007/09/05 20:20:50 jokey Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="interface bandwidth monitor"
+HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
+SRC_URI="http://people.suug.ch/~tgr/bmon/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="dbi rrdtool"
+
+DEPEND=">=sys-libs/ncurses-5.3-r2
+ >=dev-libs/libnl-0.5.0
+ dbi? ( >=dev-db/libdbi-0.7.2-r1 )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.6-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # gcc4 fix, bug 105343
+ epatch "${FILESDIR}"/${P}-gcc4.diff
+ # Don't strip, bug #144370
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+ # libnl crap, bug 176378
+ epatch "${FILESDIR}"/${P}-libnl-1.0.patch
+
+}
+
+src_compile() {
+ econf \
+ $(use_enable dbi) \
+ $(use_enable rrdtool rrd) || die "econf failed"
+ emake CPPFLAGS="${CXXFLAGS} -I${WORKDIR}/libnl-${NLVER}/include" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}
diff --git a/net-analyzer/bmon/files/bmon-2.1.0-libnl-1.0.patch b/net-analyzer/bmon/files/bmon-2.1.0-libnl-1.0.patch
new file mode 100644
index 000000000000..32b3e21cce99
--- /dev/null
+++ b/net-analyzer/bmon/files/bmon-2.1.0-libnl-1.0.patch
@@ -0,0 +1,23 @@
+--- configure~ 2007-09-03 23:46:20.000000000 +0200
++++ configure 2007-09-03 23:46:20.000000000 +0200
+@@ -7327,13 +7327,13 @@ echo "$as_me:$LINENO: result: $ac_cv_lib
+ echo "${ECHO_T}$ac_cv_lib_nl_nl_connect" >&6
+ if test $ac_cv_lib_nl_nl_connect = yes; then
+
+-
+-cat >>confdefs.h <<_ACEOF
+-#define HAVE_NL "1"
+-_ACEOF
+-
+- LIBNL="-lnl"
+- NL="Yes"
++ case ${target_os} in
++ *linux*)
++ echo
++ echo "*** Warning: Building bmon on Linuxx w/o libnl ***"
++ echo
++ ;;
++ esac
+
+ else
+
diff --git a/net-analyzer/bmon/files/digest-bmon-2.1.0-r3 b/net-analyzer/bmon/files/digest-bmon-2.1.0-r3
new file mode 100644
index 000000000000..f5cb3bca416b
--- /dev/null
+++ b/net-analyzer/bmon/files/digest-bmon-2.1.0-r3
@@ -0,0 +1,3 @@
+MD5 3111a027907016c0902d67350c619df6 bmon-2.1.0.tar.gz 270287
+RMD160 7e0a5e0a82bfd3dc30fec899088f2206a75796a0 bmon-2.1.0.tar.gz 270287
+SHA256 36a5772fc0241298b15db3dc4fb2552dcbb43edeffd6fcea4cd8818e97ec99fe bmon-2.1.0.tar.gz 270287