summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-15 00:48:54 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-15 00:48:54 +0000
commit1812599cd4a6122f0780645a4fd5de46699251c5 (patch)
treecfda79561a144e1df5ddbe28d7d67aa2500f6ef8 /net-analyzer/nttcp
parentrevbump; patch to fix shared lib issue of libpypy-c.so wrt Bug #517002, thank... (diff)
downloadgentoo-2-1812599cd4a6122f0780645a4fd5de46699251c5.tar.gz
gentoo-2-1812599cd4a6122f0780645a4fd5de46699251c5.tar.bz2
gentoo-2-1812599cd4a6122f0780645a4fd5de46699251c5.zip
EAPI bump. Add Debian patch.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/nttcp')
-rw-r--r--net-analyzer/nttcp/ChangeLog10
-rw-r--r--net-analyzer/nttcp/files/nttcp-1.47-format-security.patch11
-rw-r--r--net-analyzer/nttcp/nttcp-1.47-r1.ebuild24
-rw-r--r--net-analyzer/nttcp/nttcp-1.47-r2.ebuild31
4 files changed, 66 insertions, 10 deletions
diff --git a/net-analyzer/nttcp/ChangeLog b/net-analyzer/nttcp/ChangeLog
index abff9ed9b055..89ce88326cc9 100644
--- a/net-analyzer/nttcp/ChangeLog
+++ b/net-analyzer/nttcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nttcp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nttcp/ChangeLog,v 1.19 2012/07/24 00:08:40 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nttcp/ChangeLog,v 1.20 2014/07/15 00:48:53 jer Exp $
+
+*nttcp-1.47-r2 (15 Jul 2014)
+
+ 15 Jul 2014; Jeroen Roovers <jer@gentoo.org> nttcp-1.47-r1.ebuild,
+ +nttcp-1.47-r2.ebuild, +files/nttcp-1.47-format-security.patch:
+ EAPI bump. Add Debian patch.
24 Jul 2012; Anthony G. Basile <blueness@gentoo.org> nttcp-1.47-r1.ebuild:
Keyword ~mips
diff --git a/net-analyzer/nttcp/files/nttcp-1.47-format-security.patch b/net-analyzer/nttcp/files/nttcp-1.47-format-security.patch
new file mode 100644
index 000000000000..7f1e4d4aa690
--- /dev/null
+++ b/net-analyzer/nttcp/files/nttcp-1.47-format-security.patch
@@ -0,0 +1,11 @@
+--- a/nttcp.c
++++ b/nttcp.c
+@@ -372,7 +372,7 @@
+ #define Message(x) fMessage(stdout, x)
+
+ void Exit(char *s, int ret) {
+- syslog(LOG_DEBUG, s);
++ syslog(LOG_DEBUG, "%s", s);
+ fMessage(stderr,s);
+ exit(ret);
+ }
diff --git a/net-analyzer/nttcp/nttcp-1.47-r1.ebuild b/net-analyzer/nttcp/nttcp-1.47-r1.ebuild
index 1c50e2346b5f..ae5bd17c4521 100644
--- a/net-analyzer/nttcp/nttcp-1.47-r1.ebuild
+++ b/net-analyzer/nttcp/nttcp-1.47-r1.ebuild
@@ -1,23 +1,31 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nttcp/nttcp-1.47-r1.ebuild,v 1.6 2012/07/24 00:08:40 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nttcp/nttcp-1.47-r1.ebuild,v 1.7 2014/07/15 00:48:53 jer Exp $
-inherit toolchain-funcs
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="tool to test TCP and UDP throughput"
HOMEPAGE="http://www.leo.org/~elmar/nttcp/"
SRC_URI="http://www.leo.org/~elmar/nttcp/${P}.tar.gz"
-
LICENSE="public-domain"
+
SLOT="0"
KEYWORDS="amd64 ~mips ~ppc x86"
-IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
src_compile() {
- emake ARCH= CC="$(tc-getCC)" OPT="${CFLAGS}" LFLAGS="${LDFLAGS}" || die "build failed"
+ emake \
+ ARCH= \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}" \
+ OPT="${CFLAGS}"
}
src_install() {
- dobin nttcp || die
- doman nttcp.1
+ dobin ${PN}
+ doman ${PN}.1
}
diff --git a/net-analyzer/nttcp/nttcp-1.47-r2.ebuild b/net-analyzer/nttcp/nttcp-1.47-r2.ebuild
new file mode 100644
index 000000000000..60a5991c64ee
--- /dev/null
+++ b/net-analyzer/nttcp/nttcp-1.47-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nttcp/nttcp-1.47-r2.ebuild,v 1.1 2014/07/15 00:48:53 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool to test TCP and UDP throughput"
+HOMEPAGE="http://www.leo.org/~elmar/nttcp/"
+SRC_URI="http://www.leo.org/~elmar/nttcp/${P}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake \
+ ARCH= \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}" \
+ OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}