summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2010-03-16 16:39:27 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2010-03-16 16:39:27 +0000
commit1b4733082764151e12d9442588ff92df99ad23d3 (patch)
tree598be33d363afd241e57ea690e15b92b8c2532ef /net-analyzer
parentAdd prefix keywords as tested in bug 309429 (diff)
downloadgentoo-2-1b4733082764151e12d9442588ff92df99ad23d3.tar.gz
gentoo-2-1b4733082764151e12d9442588ff92df99ad23d3.tar.bz2
gentoo-2-1b4733082764151e12d9442588ff92df99ad23d3.zip
Add fix for indefinitely hang while checking ping on Linux VServer (#44382), patch by Norbert Klein and Ivan Chavero
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog10
-rw-r--r--net-analyzer/nagios-plugins/files/nagios-plugins-1.4.14-vserver.patch98
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r2.ebuild (renamed from net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r1.ebuild)3
3 files changed, 109 insertions, 2 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 4a25bb9810ed..38e3a030b567 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.127 2010/01/31 17:40:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.128 2010/03/16 16:39:26 dertobi123 Exp $
+
+*nagios-plugins-1.4.14-r2 (16 Mar 2010)
+
+ 16 Mar 2010; Tobias Scherbaum <dertobi123@gentoo.org>
+ -nagios-plugins-1.4.14-r1.ebuild, +nagios-plugins-1.4.14-r2.ebuild,
+ +files/nagios-plugins-1.4.14-vserver.patch:
+ Add fix for indefinitely hang while checking ping on Linux VServer
+ (#44382), patch by Norbert Klein and Ivan Chavero
31 Jan 2010; Raúl Porcel <armin76@gentoo.org>
nagios-plugins-1.4.14.ebuild:
diff --git a/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.14-vserver.patch b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.14-vserver.patch
new file mode 100644
index 000000000000..5eb99f31b96c
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.14-vserver.patch
@@ -0,0 +1,98 @@
+--- configure.in.orig 2009-02-26 14:05:55.000000000 +0000
++++ configure.in 2009-02-26 14:07:02.000000000 +0000
+@@ -94,6 +94,8 @@
+ PKG_ARCH=`uname -p`
+ REV_DATESTAMP=`date '+%Y.%m.%d.%H.%M'`
+ REV_TIMESTAMP=`date '+%Y%m%d%H%M%S'`
++first_ip=`/sbin/ifconfig | egrep "inet addr:" | sed -n '1p' | sed 's/ Bcast.*$//' | sed 's/^\s*inet addr://'`
++
+
+ AC_SUBST(PKG_ARCH)
+ AC_SUBST(REV_DATESTAMP)
+@@ -869,14 +871,14 @@
+ fi
+
+ elif [[ "z$ac_cv_uname_s" = "zUnixWare" ]] && \
+- $PATH_TO_PING -n -s 127.0.0.1 56 1 2>/dev/null | \
++ $PATH_TO_PING -n -s $first_ip 56 1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -U -c %d %s"
+ ac_cv_ping_packets_first=yes
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
++elif $PATH_TO_PING -n -U -w 10 -c 1 $first_ip 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -U -w %d -c %d %s"
+@@ -884,52 +886,52 @@
+ ac_cv_ping_has_timeout=yes
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -U -c 1 127.0.0.1 2>/dev/null | \
++elif $PATH_TO_PING -n -U -c 1 $first_ip 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -U -c %d %s"
+ ac_cv_ping_packets_first=yes
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -c 1 127.0.0.1 2>/dev/null | \
++elif $PATH_TO_PING -n -c 1 $first_ip 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -c %d %s"
+ ac_cv_ping_packets_first=yes
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n 127.0.0.1 -c 1 2>/dev/null | \
++elif $PATH_TO_PING -n $first_ip -c 1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n %s -c %d"
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING 127.0.0.1 -n 1 2>/dev/null | \
++elif $PATH_TO_PING $first_ip -n 1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING %s -n %d"
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -s 127.0.0.1 56 1 2>/dev/null | \
++elif $PATH_TO_PING -n -s $first_ip 56 1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -s %s 56 %d"
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -h 127.0.0.1 -s 56 -c 1 2>/dev/null | \
++elif $PATH_TO_PING -n -h $first_ip -s 56 -c 1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -h %s -s 56 -c %d"
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -s 56 -c 1 127.0.0.1 2>/dev/null | \
++elif $PATH_TO_PING -n -s 56 -c 1 $first_ip 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -s 56 -c %d %s"
+ ac_cv_ping_packets_first=yes
+ AC_MSG_RESULT([$with_ping_command])
+
+-elif $PATH_TO_PING -n -c 1 127.0.0.1 2>/dev/null | \
++elif $PATH_TO_PING -n -c 1 $first_ip 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+ then
+ with_ping_command="$PATH_TO_PING -n -c %d %s"
+@@ -1132,7 +1134,7 @@
+ if test -n "$PATH_TO_NSLOOKUP"
+ then
+ AC_MSG_CHECKING(for nslookup syntax)
+- if $PATH_TO_NSLOOKUP -sil 127.0.0.1 2>&1 | grep ["Invalid option: sil"] >/dev/null
++ if $PATH_TO_NSLOOKUP -sil $first_ip 2>&1 | grep ["Invalid option: sil"] >/dev/null
+ then
+ ac_cv_nslookup_command="$PATH_TO_NSLOOKUP"
+ AC_MSG_RESULT([$ac_cv_nslookup_command])
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r2.ebuild
index 409961ed74e9..708d728ebf28 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r1.ebuild,v 1.2 2010/01/22 16:01:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.14-r2.ebuild,v 1.1 2010/03/16 16:39:26 dertobi123 Exp $
EAPI=1
@@ -55,6 +55,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.4.10-contrib.patch
epatch "${FILESDIR}"/${PN}-1.4.12-pgsqlconfigure.patch
+ epatch "${FILESDIR}"/${P}-vserver.patch
eautoreconf
}