summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 21:26:13 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 21:26:13 +0000
commit17aa07b12ac03d4e9c780c2e0dfaffdf70f7567c (patch)
tree49efa5359b9eac1f34ec11bf64e98b858020a040 /net-dns
parentMarked ppc (Manifest recommit) (diff)
downloadgentoo-2-17aa07b12ac03d4e9c780c2e0dfaffdf70f7567c.tar.gz
gentoo-2-17aa07b12ac03d4e9c780c2e0dfaffdf70f7567c.tar.bz2
gentoo-2-17aa07b12ac03d4e9c780c2e0dfaffdf70f7567c.zip
Fix use invocation
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/mydns/ChangeLog6
-rw-r--r--net-dns/mydns/mydns-0.10.3.ebuild8
-rw-r--r--net-dns/mydns/mydns-0.10.4.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/net-dns/mydns/ChangeLog b/net-dns/mydns/ChangeLog
index 6f05427b093c..56a694d1240d 100644
--- a/net-dns/mydns/ChangeLog
+++ b/net-dns/mydns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/mydns
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.5 2004/04/30 22:18:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.6 2004/06/09 21:26:13 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> mydns-0.10.3.ebuild,
+ mydns-0.10.4.ebuild:
+ Fix use invocation
*mydns-0.10.4 (01 May 2004)
diff --git a/net-dns/mydns/mydns-0.10.3.ebuild b/net-dns/mydns/mydns-0.10.3.ebuild
index 4d53461e1706..ed835d8f3b64 100644
--- a/net-dns/mydns/mydns-0.10.3.ebuild
+++ b/net-dns/mydns/mydns-0.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.3.ebuild,v 1.2 2004/04/30 22:18:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.3.ebuild,v 1.3 2004/06/09 21:26:13 agriffis Exp $
DESCRIPTION="A DNS-Server which gets its data from mysql-databases"
HOMEPAGE="http://mydns.bboy.net/"
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
sys-devel/bison"
src_compile() {
- if [ ! "`use mysql`" -a ! "`use postgres`" ] ; then
+ if ! use mysql && ! use postgres; then
eerror "MyDNS needs either MySQL or PostgreSQL."
eerror "Please set USE=\"mysql\" or USE=\"postgres\", and try again."
die
@@ -54,13 +54,13 @@ pkg_postinst() {
einfo
einfo "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
einfo "# chmod 0600 /etc/mydns.conf"
- if [ "`use mysql`" ] ; then
+ if use mysql ; then
einfo "# mysqladmin -u <username> -p create mydns"
einfo "# /usr/sbin/mydns --create-tables | mysql -u <user> -p mydns"
einfo
einfo "to create the tables in the MySQL-Database."
einfo "For more info see QUICKSTART.mysql."
- elif [ "`use postgres`" ] ; then
+ elif use postgres ; then
einfo "# createdb mydns"
einfo "# /usr/sbin/mydns --create-tables | psql mydns"
einfo
diff --git a/net-dns/mydns/mydns-0.10.4.ebuild b/net-dns/mydns/mydns-0.10.4.ebuild
index 0975947ea567..7512df96dd31 100644
--- a/net-dns/mydns/mydns-0.10.4.ebuild
+++ b/net-dns/mydns/mydns-0.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.4.ebuild,v 1.1 2004/04/30 22:18:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.4.ebuild,v 1.2 2004/06/09 21:26:13 agriffis Exp $
DESCRIPTION="A DNS-Server which gets its data from mysql-databases"
HOMEPAGE="http://mydns.bboy.net/"
@@ -19,7 +19,7 @@ DEPEND="${RDEPEND}
sys-devel/bison"
src_compile() {
- if [ ! "`use mysql`" -a ! "`use postgres`" ] ; then
+ if use mysql || use postgres; then
eerror "MyDNS needs either MySQL or PostgreSQL."
eerror "Please set USE=\"mysql\" or USE=\"postgres\", and try again."
die
@@ -53,13 +53,13 @@ pkg_postinst() {
einfo
einfo "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
einfo "# chmod 0600 /etc/mydns.conf"
- if [ "`use mysql`" ] ; then
+ if use mysql ; then
einfo "# mysqladmin -u <username> -p create mydns"
einfo "# /usr/sbin/mydns --create-tables | mysql -u <user> -p mydns"
einfo
einfo "to create the tables in the MySQL-Database."
einfo "For more info see QUICKSTART.mysql."
- elif [ "`use postgres`" ] ; then
+ elif use postgres ; then
einfo "# createdb mydns"
einfo "# /usr/sbin/mydns --create-tables | psql mydns"
einfo