summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-07-13 13:30:58 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-07-13 13:30:58 +0000
commitae09c79917a914d3723a130a6adf3880a8129259 (patch)
tree50147f4cef8e9e1364b3f88d08ca7b72f34a0458 /net-dns
parentEnable USE=ecdsa by default for better net-dns/unbound experience (diff)
downloadgentoo-2-ae09c79917a914d3723a130a6adf3880a8129259.tar.gz
gentoo-2-ae09c79917a914d3723a130a6adf3880a8129259.tar.bz2
gentoo-2-ae09c79917a914d3723a130a6adf3880a8129259.zip
Version bump with ECDSA support, bug 418369 by Guillaume Castagnino
(Portage version: 2.1.10.65/cvs/Linux i686)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog8
-rw-r--r--net-dns/unbound/unbound-1.4.13_p2.ebuild112
-rw-r--r--net-dns/unbound/unbound-1.4.15.ebuild109
-rw-r--r--net-dns/unbound/unbound-1.4.17.ebuild (renamed from net-dns/unbound/unbound-1.4.14.ebuild)28
4 files changed, 21 insertions, 236 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index d53f683d13cc..cf3a911becb2 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.41 2012/06/14 02:23:04 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.42 2012/07/13 13:30:58 darkside Exp $
+
+*unbound-1.4.17 (13 Jul 2012)
+
+ 13 Jul 2012; Jeremy Olexa <darkside@gentoo.org> -unbound-1.4.13_p2.ebuild,
+ -unbound-1.4.14.ebuild, -unbound-1.4.15.ebuild, +unbound-1.4.17.ebuild:
+ Version bump with ECDSA support, bug 418369 by Guillaume Castagnino
14 Jun 2012; Zac Medico <zmedico@gentoo.org> unbound-1.4.13_p2.ebuild,
unbound-1.4.14.ebuild, unbound-1.4.15.ebuild, unbound-1.4.16.ebuild:
diff --git a/net-dns/unbound/unbound-1.4.13_p2.ebuild b/net-dns/unbound/unbound-1.4.13_p2.ebuild
deleted file mode 100644
index c3bdbe1674b8..000000000000
--- a/net-dns/unbound/unbound-1.4.13_p2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.13_p2.ebuild,v 1.5 2012/06/14 02:23:04 zmedico Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-
-MY_P="${P/_p/p}"
-
-inherit eutils flag-o-matic python user
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="debug gost python static-libs test threads"
-
-RDEPEND="dev-libs/expat
- dev-libs/libevent
- >=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl,gost?]"
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-# bug #347415
-RDEPEND="${RDEPEND}
- net-dns/dnssec-root"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-
- use python && python_pkg_setup
-}
-
-src_prepare() {
- # To avoid below error messages, set 'trust-anchor-file' to same value in
- # 'auto-trust-anchor-file'.
- # [23109:0] error: Could not open autotrust file for writing, # /etc/dnssec/root-anchors.txt: Permission denied
- epatch "${FILESDIR}/${PN}-1.4.12-gentoo.patch"
-}
-
-src_configure() {
- append-ldflags -Wl,-z,noexecstack || die
- econf \
- --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
- --with-ldns="${EPREFIX}"/usr \
- --with-libevent="${EPREFIX}"/usr \
- --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
- $(use_enable debug) \
- $(use_enable gost) \
- $(use_enable static-libs static) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) \
- --disable-rpath || die
-
- # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
- # $(use_enable debug lock-checks) \
- # $(use_enable debug alloc-checks) \
- # $(use_enable debug alloc-lite) \
- # $(use_enable debug alloc-nonregional) \
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- find "${ED}" -name '_unbound.{la,a}' -delete || die
- fi
- if ! use static-libs ; then
- find "${ED}" -name "*.la" -type f -delete || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
-
- # bug #315519
- #exeinto /usr/libexec/munin/plugins
- #doexe contrib/unbound_munin_ || die "doexe failed"
- dodoc contrib/unbound_munin_ || die "dodoc failed"
-
- docinto selinux
- dodoc contrib/selinux/* || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/update-anchor.sh || die "doexe failed"
-}
-
-pkg_postinst() {
- use python && python_mod_optimize unbound.py unboundmodule.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup unbound.py unboundmodule.py
-}
diff --git a/net-dns/unbound/unbound-1.4.15.ebuild b/net-dns/unbound/unbound-1.4.15.ebuild
deleted file mode 100644
index c055d2425177..000000000000
--- a/net-dns/unbound/unbound-1.4.15.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.15.ebuild,v 1.3 2012/06/14 02:23:04 zmedico Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-
-inherit eutils flag-o-matic python user
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="debug gost python static-libs test threads"
-
-RDEPEND="dev-libs/expat
- dev-libs/libevent
- >=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl,gost?]"
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-# bug #347415
-RDEPEND="${RDEPEND}
- net-dns/dnssec-root"
-
-pkg_setup() {
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-
- use python && python_pkg_setup
-}
-
-src_prepare() {
- # To avoid below error messages, set 'trust-anchor-file' to same value in
- # 'auto-trust-anchor-file'.
- # [23109:0] error: Could not open autotrust file for writing,
- # /etc/dnssec/root-anchors.txt: Permission denied
- epatch "${FILESDIR}/${PN}-1.4.12-gentoo.patch"
-}
-
-src_configure() {
- append-ldflags -Wl,-z,noexecstack || die
- econf \
- --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
- --with-ldns="${EPREFIX}"/usr \
- --with-libevent="${EPREFIX}"/usr \
- --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
- $(use_enable debug) \
- $(use_enable gost) \
- $(use_enable static-libs static) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) \
- --disable-rpath || die
-
- # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
- # $(use_enable debug lock-checks) \
- # $(use_enable debug alloc-checks) \
- # $(use_enable debug alloc-lite) \
- # $(use_enable debug alloc-nonregional) \
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- find "${ED}" -name '_unbound.{la,a}' -delete || die
- fi
- if ! use static-libs ; then
- find "${ED}" -name "*.la" -type f -delete || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
-
- # bug #315519
- #exeinto /usr/libexec/munin/plugins
- #doexe contrib/unbound_munin_ || die "doexe failed"
- dodoc contrib/unbound_munin_ || die "dodoc failed"
-
- docinto selinux
- dodoc contrib/selinux/* || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/update-anchor.sh || die "doexe failed"
-}
-
-pkg_postinst() {
- use python && python_mod_optimize unbound.py unboundmodule.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup unbound.py unboundmodule.py
-}
diff --git a/net-dns/unbound/unbound-1.4.14.ebuild b/net-dns/unbound/unbound-1.4.17.ebuild
index 5604a1a191fd..5fbc890b43a7 100644
--- a/net-dns/unbound/unbound-1.4.14.ebuild
+++ b/net-dns/unbound/unbound-1.4.17.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.14.ebuild,v 1.3 2012/06/14 02:23:04 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.17.ebuild,v 1.1 2012/07/13 13:30:58 darkside Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
@@ -16,12 +16,13 @@ SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="debug gost python static-libs test threads"
+IUSE="debug gost python selinux static-libs test threads"
RDEPEND="dev-libs/expat
dev-libs/libevent
>=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl,gost?]"
+ >=net-libs/ldns-1.6.13[ecdsa,ssl,gost?]
+ selinux? ( sec-policy/selinux-bind )"
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
@@ -51,7 +52,7 @@ src_prepare() {
}
src_configure() {
- append-ldflags -Wl,-z,noexecstack || die
+ append-ldflags -Wl,-z,noexecstack
econf \
--with-pidfile="${EPREFIX}"/var/run/unbound.pid \
--with-ldns="${EPREFIX}"/usr \
@@ -63,7 +64,8 @@ src_configure() {
$(use_with threads pthreads) \
$(use_with python pyunbound) \
$(use_with python pythonmodule) \
- --disable-rpath || die
+ --enable-ecdsa \
+ --disable-rpath
# http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
# $(use_enable debug lock-checks) \
@@ -83,21 +85,19 @@ src_install() {
find "${ED}" -name "*.la" -type f -delete || die
fi
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+ newinitd "${FILESDIR}/unbound.initd" unbound
+ newconfd "${FILESDIR}/unbound.confd" unbound
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}
# bug #315519
- #exeinto /usr/libexec/munin/plugins
- #doexe contrib/unbound_munin_ || die "doexe failed"
- dodoc contrib/unbound_munin_ || die "dodoc failed"
+ dodoc contrib/unbound_munin_
docinto selinux
- dodoc contrib/selinux/* || die "dodoc failed"
+ dodoc contrib/selinux/*
exeinto /usr/share/${PN}
- doexe contrib/update-anchor.sh || die "doexe failed"
+ doexe contrib/update-anchor.sh
}
pkg_postinst() {