summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-06-08 17:12:33 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-06-08 17:12:33 +0000
commitaca4a641551c5810a1e81bc5a0c96e6abb608849 (patch)
treeb5d09998ddc13a3d1974106cf30030c5eb44d4ae /net-firewall
parentVersion bump with new config file (diff)
downloadgentoo-2-aca4a641551c5810a1e81bc5a0c96e6abb608849.tar.gz
gentoo-2-aca4a641551c5810a1e81bc5a0c96e6abb608849.tar.bz2
gentoo-2-aca4a641551c5810a1e81bc5a0c96e6abb608849.zip
Version bump with new config file
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/files/shorewallrc21
-rw-r--r--net-firewall/shorewall6/shorewall6-4.5.4.2.ebuild61
3 files changed, 89 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index b29b7acb2800..e9c855fc2920 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.51 2012/05/20 08:42:57 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.52 2012/06/08 17:12:33 constanze Exp $
+
+*shorewall6-4.5.4.2 (08 Jun 2012)
+
+ 08 Jun 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.5.4.2.ebuild, +files/shorewallrc:
+ Version bump with new config file
20 May 2012; Mark Loeser <halcy0n@gentoo.org> shorewall6-4.4.23.2.ebuild:
Stable for ppc/ppc64; bug #388195
diff --git a/net-firewall/shorewall6/files/shorewallrc b/net-firewall/shorewall6/files/shorewallrc
new file mode 100644
index 000000000000..4f13769114a4
--- /dev/null
+++ b/net-firewall/shorewall6/files/shorewallrc
@@ -0,0 +1,21 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD= #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=etc/init.d #Directory where SysV init scripts are installed.
+INITFILE=$PRODUCT #Name of the product's installed SysV init script
+INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARDIR=/var/lib #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall6/shorewall6-4.5.4.2.ebuild b/net-firewall/shorewall6/shorewall6-4.5.4.2.ebuild
new file mode 100644
index 000000000000..597f0e0ac510
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.5.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.5.4.2.ebuild,v 1.1 2012/06/08 17:12:33 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ keepdir /var/lock/subsys
+}