summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-03-12 12:40:11 +0000
committerAlex Alexander <wired@gentoo.org>2010-03-12 12:40:11 +0000
commit8a5ee095d288a48c571b351a2b2cfe9b94919c43 (patch)
tree69c864fb56b59e80ebbf9631c5296611c9c81155 /net-irc
parentFix bug 302900 (diff)
downloadgentoo-2-8a5ee095d288a48c571b351a2b2cfe9b94919c43.tar.gz
gentoo-2-8a5ee095d288a48c571b351a2b2cfe9b94919c43.tar.bz2
gentoo-2-8a5ee095d288a48c571b351a2b2cfe9b94919c43.zip
[net-irc/znc] 0.080 version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.080.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 38e0d512e064..231b4ff15603 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.28 2010/01/19 14:23:53 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.29 2010/03/12 12:40:11 wired Exp $
+
+*znc-0.080 (12 Mar 2010)
+
+ 12 Mar 2010; Alex Alexander <wired@gentoo.org> +znc-0.080.ebuild:
+ version bump
*znc-0.078 (19 Jan 2010)
diff --git a/net-irc/znc/znc-0.080.ebuild b/net-irc/znc/znc-0.080.ebuild
new file mode 100644
index 000000000000..91097cdf0087
--- /dev/null
+++ b/net-irc/znc/znc-0.080.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.080.ebuild,v 1.1 2010/03/12 12:40:11 wired Exp $
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ares debug extras ipv6 nomodules perl ssl sasl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ares? ( net-dns/c-ares )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable !nomodules modules) \
+ $(use_enable perl) \
+ $(use_enable ssl openssl) \
+ $(use_enable sasl) \
+ $(use_enable ares c-ares) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}