summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2012-04-08 18:17:44 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2012-04-08 18:17:44 +0000
commit9e0d193045325fb55108f0a10bd60b86eb4b94d2 (patch)
treedbfd0dda0e2f0d24a8eb97d207b19a4fa19f37e2 /net-libs/libtorrent/libtorrent-0.13.1.ebuild
parentCleanup old versions, revision-bump the rest adding selinux policy dependency... (diff)
downloadgentoo-2-9e0d193045325fb55108f0a10bd60b86eb4b94d2.tar.gz
gentoo-2-9e0d193045325fb55108f0a10bd60b86eb4b94d2.tar.bz2
gentoo-2-9e0d193045325fb55108f0a10bd60b86eb4b94d2.zip
Version bump (#411041)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.13.1.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.13.1.ebuild b/net-libs/libtorrent/libtorrent-0.13.1.ebuild
new file mode 100644
index 000000000000..819a36605ba2
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.13.1.ebuild,v 1.1 2012/04/08 18:17:44 sochotnicky Exp $
+
+EAPI=4
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+# epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}