summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-24 07:09:06 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-24 07:09:06 +0000
commit53c04ffde442086d91af23efbc7c89d8a77e3b5f (patch)
treeebbd319d43abac213ed4778d89991aae86695497 /net-misc/aiccu
parentRemove bad xen/qemu mask (diff)
downloadgentoo-2-53c04ffde442086d91af23efbc7c89d8a77e3b5f.tar.gz
gentoo-2-53c04ffde442086d91af23efbc7c89d8a77e3b5f.tar.bz2
gentoo-2-53c04ffde442086d91af23efbc7c89d8a77e3b5f.zip
Add systemd support (thanks Łukasz Stelmach, bug 444692)
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/aiccu')
-rw-r--r--net-misc/aiccu/ChangeLog8
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r1.ebuild52
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r3.ebuild54
-rw-r--r--net-misc/aiccu/files/aiccu-2007.01.15-systemd.patch52
4 files changed, 113 insertions, 53 deletions
diff --git a/net-misc/aiccu/ChangeLog b/net-misc/aiccu/ChangeLog
index 1c7376764ec3..21f179f50cdb 100644
--- a/net-misc/aiccu/ChangeLog
+++ b/net-misc/aiccu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/aiccu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.41 2013/02/28 14:34:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.42 2013/05/24 07:09:06 xmw Exp $
+
+*aiccu-2007.01.15-r3 (24 May 2013)
+
+ 24 May 2013; Michael Weber <xmw@gentoo.org> +aiccu-2007.01.15-r3.ebuild,
+ +files/aiccu-2007.01.15-systemd.patch, -aiccu-2007.01.15-r1.ebuild:
+ Add systemd support (thanks Łukasz Stelmach, bug 444692)
28 Feb 2013; Jeroen Roovers <jer@gentoo.org> aiccu-2007.01.15-r2.ebuild:
Stable for HPPA (bug #457440).
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild
deleted file mode 100644
index 61ca1f27b938..000000000000
--- a/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild,v 1.7 2012/08/01 06:39:07 xmw Exp $
-
-EAPI=3
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
-HOMEPAGE="http://www.sixxs.net/tools/aiccu"
-SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
-
-LICENSE="SixXS"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ppc sparc x86"
-IUSE=""
-
-DEPEND="net-libs/gnutls
- sys-apps/iproute2"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/aiccu
-
-src_prepare() {
- epatch "${FILESDIR}/aiccu.init.gentoo.patch" \
- "${FILESDIR}/${P}-Makefile.patch"
-}
-
-src_compile() {
- # Don't use main Makefile since it requires additional dependencies which
- # are useless for us.
- emake CC=$(tc-getCC) STRIP= -C unix-console || die
-}
-
-src_install() {
- dosbin unix-console/aiccu || die
-
- insopts -m 600
- insinto /etc
- doins doc/aiccu.conf || die
-
- dodoc doc/{HOWTO,README,changelog}
-
- newinitd doc/aiccu.init.gentoo aiccu || die
-}
-
-pkg_postinst() {
- einfo "The aiccu ebuild installs an init script named 'aiccu'"
- einfo "To add support for a SixXS connection at startup, do"
- einfo "edit your /etc/aiccu.conf and do"
- einfo "# rc-update add aiccu default"
-}
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r3.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r3.ebuild
new file mode 100644
index 000000000000..ea9b9cb66115
--- /dev/null
+++ b/net-misc/aiccu/aiccu-2007.01.15-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r3.ebuild,v 1.1 2013/05/24 07:09:06 xmw Exp $
+
+EAPI=5
+
+inherit eutils linux-info systemd toolchain-funcs
+
+DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
+HOMEPAGE="http://www.sixxs.net/tools/aiccu"
+SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
+
+LICENSE="SixXS"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="systemd"
+
+RDEPEND="net-libs/gnutls
+ sys-apps/iproute2
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-r2-init.gentoo.patch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-setupscript.patch \
+ "${FILESDIR}"/${P}-uclibc.patch \
+ "${FILESDIR}"/${P}-systemd.patch
+}
+
+src_compile() {
+ # Don't use main Makefile since it requires additional
+ # dependencies which are useless for us.
+ emake CC=$(tc-getCC) STRIP= -C unix-console \
+ HAVE_SYSTEMD=$(usex systemd 1 0)
+}
+
+src_install() {
+ dosbin unix-console/${PN}
+
+ insopts -m 600
+ insinto /etc
+ doins doc/${PN}.conf
+ newinitd doc/${PN}.init.gentoo ${PN}
+
+ use systemd && systemd_dounit doc/${PN}.service
+
+ dodoc doc/{HOWTO,README,changelog}
+}
diff --git a/net-misc/aiccu/files/aiccu-2007.01.15-systemd.patch b/net-misc/aiccu/files/aiccu-2007.01.15-systemd.patch
new file mode 100644
index 000000000000..a7ead9831438
--- /dev/null
+++ b/net-misc/aiccu/files/aiccu-2007.01.15-systemd.patch
@@ -0,0 +1,52 @@
+--- /dev/null
++++ aiccu-2007.01.15/doc/aiccu.service
+@@ -0,0 +1,13 @@
++[Unit]
++Description=Automatic IPv6 Connectivity Client Utility
++After=time-sync.target network.target
++ConditionPathExists=/etc/aiccu.conf
++
++
++[Service]
++Type=notify
++ExecStart=/usr/sbin/aiccu start
++ExecStop=/usr/sbin/aiccu stop
++
++[Install]
++WantedBy=multi-user.target
+--- aiccu-2007.01.15/unix-console/Makefile
++++ aiccu-2007.01.15/unix-console/Makefile
+@@ -48,6 +48,10 @@ ifeq ($(shell uname | grep -c "Linux"),1)
+ SRCS += ../common/aiccu_linux.c
+ OBJS += ../common/aiccu_linux.o
+ LIBS += -lpthread -lresolv
++ifeq (1,HAVE_SYSTEMD)
++LIBS += -lsystemd-daemon
++CFLAGS += -DHAVE_SYSTEMD
++endif
+ endif
+
+ # FreeBSD
+--- aiccu-2007.01.15/unix-console/main.c
++++ aiccu-2007.01.15/unix-console/main.c
+@@ -12,6 +12,9 @@
+
+ #include "../common/aiccu.h"
+ #include "../common/tun.h"
++#ifdef HAVE_SYSTEMD
++#include <systemd/sd-daemon.h>
++#endif
+
+ #ifndef _WIN32
+ /* Enable/Disable heartbeating */
+@@ -478,6 +481,10 @@ int main(int argc, char *argv[])
+ aiccu_exec("%s", g_aiccu->setupscript);
+ }
+
++#ifdef HAVE_SYSTEMD
++ /* Tell systemd we are operational. */
++ sd_notify(0, "READY=1");
++#endif
+
+ /* We need to stay running when doing Heartbeat or AYIYA */
+ if ( strcasecmp(hTunnel->sType, "6in4-heartbeat") == 0 ||