summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-04 13:17:20 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-04 13:17:20 +0000
commit4cf7982d6282c11ea9304fd225c801a76d583ce0 (patch)
tree09bbc47847842671b793f02d29862ffa840779a0 /net-misc/ser2net
parentStable for amd64 wrt bug #505842 (diff)
downloadgentoo-2-4cf7982d6282c11ea9304fd225c801a76d583ce0.tar.gz
gentoo-2-4cf7982d6282c11ea9304fd225c801a76d583ce0.tar.bz2
gentoo-2-4cf7982d6282c11ea9304fd225c801a76d583ce0.zip
Version bump to 2.9.1, contribution by Brendan Horan whom will proxy maintain this package; fixes bug #464720, reported by Wolfram Schlich (wschlich). Adapted to EAPI 5, removed and/or redundant code by shorter and easier alternatives.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-misc/ser2net')
-rw-r--r--net-misc/ser2net/ChangeLog13
-rw-r--r--net-misc/ser2net/metadata.xml7
-rw-r--r--net-misc/ser2net/ser2net-2.9.1.ebuild32
3 files changed, 47 insertions, 5 deletions
diff --git a/net-misc/ser2net/ChangeLog b/net-misc/ser2net/ChangeLog
index 670b2c9ecf21..193aa74c46b0 100644
--- a/net-misc/ser2net/ChangeLog
+++ b/net-misc/ser2net/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/ser2net
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ChangeLog,v 1.33 2013/10/12 07:02:37 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ChangeLog,v 1.34 2014/04/04 13:17:20 tomwij Exp $
+
+*ser2net-2.9.1 (04 Apr 2014)
+
+ 04 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +ser2net-2.9.1.ebuild,
+ metadata.xml:
+ Version bump to 2.9.1, contribution by Brendan Horan whom will proxy maintain
+ this package; fixes bug #464720, reported by Wolfram Schlich (wschlich).
+ Adapted to EAPI 5, removed and/or redundant code by shorter and easier
+ alternatives.
12 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #472084
diff --git a/net-misc/ser2net/metadata.xml b/net-misc/ser2net/metadata.xml
index ff62877c67ae..001500852c22 100644
--- a/net-misc/ser2net/metadata.xml
+++ b/net-misc/ser2net/metadata.xml
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan Horan</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-misc/ser2net/ser2net-2.9.1.ebuild b/net-misc/ser2net/ser2net-2.9.1.ebuild
new file mode 100644
index 000000000000..a88d288c0303
--- /dev/null
+++ b/net-misc/ser2net/ser2net-2.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ser2net/ser2net-2.9.1.ebuild,v 1.1 2014/04/04 13:17:20 tomwij Exp $
+
+EAPI=5
+
+DESCRIPTION="Serial To Network Proxy"
+SRC_URI="mirror://sourceforge/ser2net/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/ser2net"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+IUSE="tcpd"
+
+src_configure() {
+ econf $(use_with tcpd tcp-wrappers) --with-uucp-locking
+}
+
+src_install () {
+ default
+
+ insinto /etc
+ newins ${PN}.conf ${PN}.conf.dist
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}