summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-11-20 15:56:38 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-11-20 15:56:38 +0000
commit1b6b94a4917838fd212940c6dec3d3a83c7e5327 (patch)
tree31f5ab91679a4f78afd119684be1f7404bcec734 /net-misc/ssh-askpass-fullscreen
parentbug fix release from upstream. adds GtkStatusIcon support (diff)
downloadgentoo-2-1b6b94a4917838fd212940c6dec3d3a83c7e5327.tar.gz
gentoo-2-1b6b94a4917838fd212940c6dec3d3a83c7e5327.tar.bz2
gentoo-2-1b6b94a4917838fd212940c6dec3d3a83c7e5327.zip
minor additions to respect compiler and CFLAGS. bug #247700, thanks to justin for the patch.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.6 x86_64)
Diffstat (limited to 'net-misc/ssh-askpass-fullscreen')
-rw-r--r--net-misc/ssh-askpass-fullscreen/ChangeLog9
-rw-r--r--net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r1.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/ssh-askpass-fullscreen/ChangeLog b/net-misc/ssh-askpass-fullscreen/ChangeLog
index e4700fda0de3..4580bcc313c9 100644
--- a/net-misc/ssh-askpass-fullscreen/ChangeLog
+++ b/net-misc/ssh-askpass-fullscreen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/ssh-askpass-fullscreen
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh-askpass-fullscreen/ChangeLog,v 1.4 2008/11/20 10:15:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh-askpass-fullscreen/ChangeLog,v 1.5 2008/11/20 15:56:38 darkside Exp $
+
+*ssh-askpass-fullscreen-0.4-r1 (20 Nov 2008)
+
+ 20 Nov 2008; Jeremy Olexa <darkside@gentoo.org>
+ +ssh-askpass-fullscreen-0.4-r1.ebuild:
+ minor additions to respect compiler and CFLAGS. bug #247700, thanks to
+ justin for the patch.
20 Nov 2008; Raúl Porcel <armin76@gentoo.org>
ssh-askpass-fullscreen-0.4.ebuild:
diff --git a/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r1.ebuild b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r1.ebuild
new file mode 100644
index 000000000000..b3853f8a21bc
--- /dev/null
+++ b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4-r1.ebuild,v 1.1 2008/11/20 15:56:38 darkside Exp $
+
+DESCRIPTION="A small SSH Askpass replacement written with GTK2."
+HOMEPAGE="https://www.cgabriel.org/software/wiki/SshAskpassFullscreen"
+SRC_URI="http://www.cgabriel.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ !net-misc/gtk2-ssh-askpass"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '2 s/$/$\(LDFLAGS\)/' Makefile
+}
+
+src_compile() {
+
+ sed "s:gcc:$(tc-getCC) ${CFLAGS}:g" \
+ -i Makefile
+
+ emake LDFLAGS="${LDFLAGS}" || \
+ die "compile failed"
+}
+
+src_install() {
+ dobin ssh-askpass-fullscreen
+ doenvd "${FILESDIR}"/99ssh_askpass
+ dodoc README AUTHORS
+ #doman debian/gtk2-ssh-askpass.1
+}