summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 14:22:20 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 14:22:20 +0000
commit055f34b478c6c70e2d04f5510bc361b36cd5ab9c (patch)
treea464625220214a306d990b98f9a5b301f8c60e37 /net-p2p/dchub
parentQA: Use full atoms for best_version, has_version and built_with_use queries. (diff)
downloadgentoo-2-055f34b478c6c70e2d04f5510bc361b36cd5ab9c.tar.gz
gentoo-2-055f34b478c6c70e2d04f5510bc361b36cd5ab9c.tar.bz2
gentoo-2-055f34b478c6c70e2d04f5510bc361b36cd5ab9c.zip
Fixed DEPEND and HOMEPAGE variable by aye, bug #58824. Added to ~amd64
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-p2p/dchub')
-rw-r--r--net-p2p/dchub/ChangeLog6
-rw-r--r--net-p2p/dchub/dchub-0.5.2.ebuild23
-rw-r--r--net-p2p/dchub/files/dchub-0.5.2-amd64.patch12
3 files changed, 34 insertions, 7 deletions
diff --git a/net-p2p/dchub/ChangeLog b/net-p2p/dchub/ChangeLog
index 2a8040e595fa..e5bc1ff607a5 100644
--- a/net-p2p/dchub/ChangeLog
+++ b/net-p2p/dchub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/dchub
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/ChangeLog,v 1.19 2005/06/27 07:20:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/ChangeLog,v 1.20 2005/07/13 14:22:20 sekretarz Exp $
+
+ 13 Jul 2005; <sekretarz@gentoo.org> +files/dchub-0.5.2-amd64.patch,
+ dchub-0.5.2.ebuild:
+ Fixed DEPEND and HOMEPAGE variable by aye, bug #58824. Added to ~amd64
27 Jun 2005; Markus Rothe <corsair@gentoo.org> dchub-0.5.2.ebuild:
Stable on ppc64
diff --git a/net-p2p/dchub/dchub-0.5.2.ebuild b/net-p2p/dchub/dchub-0.5.2.ebuild
index 985e47dc905b..0fd33520001f 100644
--- a/net-p2p/dchub/dchub-0.5.2.ebuild
+++ b/net-p2p/dchub/dchub-0.5.2.ebuild
@@ -1,25 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/dchub-0.5.2.ebuild,v 1.7 2005/06/27 07:20:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/dchub-0.5.2.ebuild,v 1.8 2005/07/13 14:22:20 sekretarz Exp $
+
+inherit eutils
IUSE=""
-HOMEPAGE="http://brainz.servebeer.com/dctc/#dchub"
+HOMEPAGE="http://ac2i.homelinux.com/dctc/#dchub"
DESCRIPTION="dchub (Direct Connect Hub), a linux hub for the p2p 'direct connect'"
SRC_URI="http://brainz.servebeer.com/dctc/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc ppc64 x86"
+KEYWORDS="ppc ppc64 x86 ~amd64"
RDEPEND="virtual/libc
- =dev-libs/glib-1*
- dev-lang/perl
- dev-db/edb"
+ =dev-libs/glib-2*
+ sys-devel/libperl
+ dev-libs/libxml2
+ dev-libs/libgcrypt
+ sys-libs/zlib"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
src_install() {
make DESTDIR=${D} install || die "install problem"
diff --git a/net-p2p/dchub/files/dchub-0.5.2-amd64.patch b/net-p2p/dchub/files/dchub-0.5.2-amd64.patch
new file mode 100644
index 000000000000..446b9ddc136f
--- /dev/null
+++ b/net-p2p/dchub/files/dchub-0.5.2-amd64.patch
@@ -0,0 +1,12 @@
+diff -Naur dchub-0.5.2.orig/plugin/Makefile.am dchub-0.5.2/plugin/Makefile.am
+--- dchub-0.5.2.orig/plugin/Makefile.am 2003-11-28 15:29:40.000000000 +0000
++++ dchub-0.5.2/plugin/Makefile.am 2005-07-13 16:01:01.000000000 +0000
+@@ -6,7 +6,7 @@
+ SUFFIXES = .c .o .so
+
+ .c.o:
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) $(GLIB_CFLAGS) -o $@ $<
++ $(CC) -c $(CFLAGS) -fPIC $(CPPFLAGS) $(GLIB_CFLAGS) -o $@ $<
+ .o.so:
+ $(CC) -fPIC -shared $(CFLAGS) $(GLIB_CFLAGS) $< -o $@
+