summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-09-23 17:35:12 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-09-23 17:35:12 +0000
commitf17bed74a896b5fdd075d4563e0bea15913752ba (patch)
treef71ada107bab86a54438a15058eb9905a5e2be4a /sci-astronomy
parentUpgrade to EAPI 3 for prefix users #353066 by Jeremy Olexa. (diff)
downloadgentoo-2-f17bed74a896b5fdd075d4563e0bea15913752ba.tar.gz
gentoo-2-f17bed74a896b5fdd075d4563e0bea15913752ba.tar.bz2
gentoo-2-f17bed74a896b5fdd075d4563e0bea15913752ba.zip
Version bump, EAPI4, fix install phase via patch instead of using helpers. Drop old
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cdsclient/ChangeLog10
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.6.ebuild35
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.6b.ebuild (renamed from sci-astronomy/cdsclient/cdsclient-3.6a.ebuild)27
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-gentoo.diff92
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch40
5 files changed, 111 insertions, 93 deletions
diff --git a/sci-astronomy/cdsclient/ChangeLog b/sci-astronomy/cdsclient/ChangeLog
index db6177f8ec0e..75135a85de7b 100644
--- a/sci-astronomy/cdsclient/ChangeLog
+++ b/sci-astronomy/cdsclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-astronomy/cdsclient
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/ChangeLog,v 1.8 2011/08/04 18:29:29 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/ChangeLog,v 1.9 2011/09/23 17:35:12 xarthisius Exp $
+
+*cdsclient-3.6b (23 Sep 2011)
+
+ 23 Sep 2011; Kacper Kowalik <xarthisius@gentoo.org> -cdsclient-3.6.ebuild,
+ -cdsclient-3.6a.ebuild, +cdsclient-3.6b.ebuild, +files/cdsclient-gentoo.diff,
+ -files/cdsclient-makefile.in.patch:
+ Version bump, EAPI4, fix install phase via patch instead of using helpers.
+ Drop old
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/cdsclient/cdsclient-3.6.ebuild b/sci-astronomy/cdsclient/cdsclient-3.6.ebuild
deleted file mode 100644
index 597136c89866..000000000000
--- a/sci-astronomy/cdsclient/cdsclient-3.6.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/cdsclient-3.6.ebuild,v 1.1 2010/10/01 18:47:20 bicatali Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Collection of scripts to access the CDS databases"
-HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
-SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="app-shells/tcsh"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-makefile.in.patch
- # remove non standard "mantex" page
- sed -i \
- -e 's/aclient.tex//' \
- "${S}"/configure || die "sed failed"
-}
-
-src_install() {
- dodir /usr/bin
- dodir /usr/share/man
- dodir /usr/$(get_libdir)
- emake \
- PREFIX="${D}"/usr \
- MANDIR="${D}"/usr/share/man \
- LIBDIR="${D}"/usr/$(get_libdir) \
- install || die "emake install failed"
-}
diff --git a/sci-astronomy/cdsclient/cdsclient-3.6a.ebuild b/sci-astronomy/cdsclient/cdsclient-3.6b.ebuild
index 00fc80ae836d..7803aa8f6aca 100644
--- a/sci-astronomy/cdsclient/cdsclient-3.6a.ebuild
+++ b/sci-astronomy/cdsclient/cdsclient-3.6b.ebuild
@@ -1,36 +1,29 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/cdsclient-3.6a.ebuild,v 1.1 2011/07/25 22:57:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/cdsclient-3.6b.ebuild,v 1.1 2011/09/23 17:35:12 xarthisius Exp $
-EAPI=2
-inherit eutils
+EAPI=4
+
+inherit eutils versionator
DESCRIPTION="Collection of scripts to access the CDS databases"
HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
DEPEND=""
RDEPEND="app-shells/tcsh"
-S="${WORKDIR}/${PN}-3.6"
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-makefile.in.patch
+ epatch "${FILESDIR}"/${PN}-gentoo.diff
# remove non standard "mantex" page
sed -i \
-e 's/aclient.tex//' \
- "${S}"/configure || die "sed failed"
-}
-
-src_install() {
- dodir /usr/bin
- dodir /usr/share/man
- dodir /usr/$(get_libdir)
- emake \
- PREFIX="${D}"/usr \
- MANDIR="${D}"/usr/share/man \
- LIBDIR="${D}"/usr/$(get_libdir) \
- install || die "emake install failed"
+ "${S}"/configure || die
}
diff --git a/sci-astronomy/cdsclient/files/cdsclient-gentoo.diff b/sci-astronomy/cdsclient/files/cdsclient-gentoo.diff
new file mode 100644
index 000000000000..c01253da9914
--- /dev/null
+++ b/sci-astronomy/cdsclient/files/cdsclient-gentoo.diff
@@ -0,0 +1,92 @@
+Respect LDFLAGS,CFLAGS, fix install
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -35,10 +35,10 @@
+ #################################################################
+
+ INCDIR = $(PREFIX)/include
+-LIBDIR = $(PREFIX)/lib
++LIBDIR = $(PREFIX)/@libdir@
+ BINDIR = $(PREFIX)/bin
+ SHSDIR = $(PREFIX)/bin
+-MANDIR = $(PREFIX)/man
++MANDIR = $(PREFIX)/share/man
+ ###########
+ # NOTE: The definition below is required only on SOLARIS
+ # Comment the following line if required
+@@ -59,7 +59,6 @@
+ DEBUG =
+ C_OPT = -O
+ SYS =
+-CFLAGS = $(C_OPT) $(DEBUG) $(SYS) -I.
+
+ # FILES --------------------------------
+ VERFILE = $(PREFIX)/versions
+@@ -94,7 +93,7 @@
+ # RULES --------------------------------
+ .SUFFIXES: .o .c
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) -I. -c $<
+
+ # DEPENDENCIES --------------------------------
+
+@@ -113,43 +112,41 @@
+ # rm -f $$f; ln finducac2 $$f; done
+
+ aclient: aclient.o $(OBJ)
+- $(CC) $@.o $(OBJ) $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(LDFLAGS) $@.o $(OBJ) $(LIBSYS) -o $@
+
+ wwwget: wwwget.c
+- $(CC) wwwget.c $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(LDFLAGS) wwwget.c $(LIBSYS) -o $@
+
+ doc: sk.tex man.tex aclient.tex
+ latex man.tex
+
+-install: $(EXPORT_INSTALL) install_shs install_info
++install: $(EXPORT_INSTALL) install_shs
+ rm -rf *.cache
+
+ export_install: install_bin install_man
+
+ install_man: $(MAN)
+- if [ -d $(MANDIR) ]; then echo $(MANDIR) exists; \
+- else mkdir $(MANDIR); fi
++ if [ -d $(DESTDIR)$(MANDIR) ]; then echo $(DESTDIR)$(MANDIR) exists; \
++ else mkdir -p $(DESTDIR)$(MANDIR); fi
+ for f in $(MAN); do \
+ e=`echo $$f | cut -d. -f2`; \
+- if [ -d $(MANDIR)/man$$e ] ; then echo $(MANDIR)/man$$e exists ; \
+- else mkdir $(MANDIR)/man$$e ; fi ; \
+- $(COPY) $$f $(MANDIR)/man$$e ; \
++ if [ -d $(DESTDIR)$(MANDIR)/man$$e ] ; then echo $(DESTDIR)$(MANDIR)/man$$e exists ; \
++ else mkdir -p $(DESTDIR)$(MANDIR)/man$$e ; fi ; \
++ $(COPY) $$f $(DESTDIR)$(MANDIR)/man$$e ; \
+ done
+
+ install_h: $(INC)
+- test -d $(INCDIR) || mkdir $(INCDIR)
+- $(COPY) $(INC) $(INCDIR)
++ test -d $(DESTDIR)$(INCDIR) || mkdir -p $(DESTDIR)$(INCDIR)
++ $(COPY) $(INC) $(DESTDIR)$(INCDIR)
+
+ install_bin: $(BIN)
+- test -d $(BINDIR) || mkdir $(BINDIR)
+- $(COPY) $(BIN) $(BINDIR)
++ test -d $(DESTDIR)$(BINDIR) || mkdir -p $(DESTDIR)$(BINDIR)
++ $(COPY) $(BIN) $(DESTDIR)$(BINDIR)
+
+ install_shs: Makefile
+- test -d $(SHSDIR) || mkdir $(SHSDIR)
++ test -d $(DESTDIR)$(SHSDIR) || mkdir -p $(DESTDIR)$(SHSDIR)
+ cdsutil="$(SHSatCDS)"; test -z "$(atCDS)" && cdsutil=""; \
+- cp -p $(SHS) $$cdsutil $(SHSDIR)
++ cp -p $(SHS) $$cdsutil $(DESTDIR)$(SHSDIR)
+
+ install_info:
+ touch $(VERFILE)
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch
deleted file mode 100644
index c0dd3e06f166..000000000000
--- a/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- Makefile.in.orig 2009-02-17 21:45:45.469037983 +0000
-+++ Makefile.in 2009-02-17 22:01:42.960921967 +0000
-@@ -59,7 +59,6 @@
- DEBUG =
- C_OPT = -O
- SYS =
--CFLAGS = $(C_OPT) $(DEBUG) $(SYS) -I.
-
- # FILES --------------------------------
- VERFILE = $(PREFIX)/versions
-@@ -91,7 +90,7 @@
- # RULES --------------------------------
- .SUFFIXES: .o .c
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-+ $(CC) $(CFLAGS) -I. -c $<
-
- # DEPENDENCIES --------------------------------
-
-@@ -110,17 +109,15 @@
- rm -f $$f; ln finducac2 $$f; done
-
- aclient: aclient.o $(OBJ)
-- $(CC) $@.o $(OBJ) $(LIBSYS) -o $@
-- $(STRIP) $@
-+ $(CC) $(LDFLAGS) $@.o $(OBJ) $(LIBSYS) -o $@
-
- wwwget: wwwget.c
-- $(CC) wwwget.c $(LIBSYS) -o $@
-- $(STRIP) $@
-+ $(CC) $(LDFLAGS) wwwget.c $(LIBSYS) -o $@
-
- doc: sk.tex man.tex aclient.tex
- latex man.tex
-
--install: $(EXPORT_INSTALL) install_shs install_info
-+install: $(EXPORT_INSTALL) install_shs
- rm -rf *.cache
-
- export_install: install_bin install_man