summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 10:13:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 10:13:06 +0000
commit4f344330979c8fbc0289b170067f3e952c52b0e1 (patch)
tree3e604269c75ed654b050b71408ec79efe5d90911 /sci-chemistry/dssp
parentNew addition for NMR assignment and structure calculation software (diff)
downloadgentoo-2-4f344330979c8fbc0289b170067f3e952c52b0e1.tar.gz
gentoo-2-4f344330979c8fbc0289b170067f3e952c52b0e1.tar.bz2
gentoo-2-4f344330979c8fbc0289b170067f3e952c52b0e1.zip
New addition
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/dssp')
-rw-r--r--sci-chemistry/dssp/ChangeLog21
-rw-r--r--sci-chemistry/dssp/dssp-070831.ebuild46
-rw-r--r--sci-chemistry/dssp/files/Makefile7
-rw-r--r--sci-chemistry/dssp/metadata.xml8
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/ChangeLog b/sci-chemistry/dssp/ChangeLog
new file mode 100644
index 000000000000..1b0b32a1b6db
--- /dev/null
+++ b/sci-chemistry/dssp/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for sci-chemistry/dssp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/ChangeLog,v 1.1 2010/03/07 10:13:05 jlec Exp $
+
+*dssp-070831 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +dssp-070831.ebuild,
+ +files/Makefile, +metadata.xml:
+ The DSSP program was designed by Wolfgang Kabsch and Chris Sander to
+ standardize secondary structure assignment. DSSP is a database of
+ secondary structure assignments (and much more) for all protein entries in
+ the Protein Data Bank (PDB). DSSP is also the program that calculates DSSP
+ entries from PDB entries.
+
+ If you use DSSP, please quote:
+
+ Dictionary of protein secondary structure: pattern recognition of
+ hydrogen-bonded and geometrical features.
+ Biopolymers. 1983 Dec;22(12):2577-637.
+ PMID: 6667333; UI: 84128824.
+
diff --git a/sci-chemistry/dssp/dssp-070831.ebuild b/sci-chemistry/dssp/dssp-070831.ebuild
new file mode 100644
index 000000000000..30dde1d70ade
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-070831.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/dssp-070831.ebuild,v 1.1 2010/03/07 10:13:05 jlec Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
+#SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dsspcmbi.tar.gz"
+SRC_URI="${P}cmbi.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="fetch"
+
+S="${WORKDIR}"/${PN}
+
+pkg_nofetch() {
+ elog "Download ftp://ftp.cmbi.ru.nl/pub/molbio/software/dsspcmbi.tar.gz --"
+ elog "Rename it to ${A} and place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile .
+ append-flags -DGCC
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin dssp || die
+ dodoc README.TXT || die
+ dohtml index.html || die
+}
+
+pkg_postinst() {
+ elog "Go to ${HOMEPAGE} and return the license agreement."
+ elog "One of its requirements is citing the article:"
+ elog "Kabsch, W. & Sander, C. Biopolymers 22:2577-2637 (1983)."
+}
diff --git a/sci-chemistry/dssp/files/Makefile b/sci-chemistry/dssp/files/Makefile
new file mode 100644
index 000000000000..575202ebbe2d
--- /dev/null
+++ b/sci-chemistry/dssp/files/Makefile
@@ -0,0 +1,7 @@
+#OBJ = AccSurf.o CalcAccSurf.o Contacts.o Date.o Dssp.o DsspCMBI.o p2clib.o Vector.o
+OBJ = AccSurf.o CalcAccSurf.o Contacts.o Date.o DsspCMBI.o p2clib.o Vector.o
+
+LIBS = -lm
+
+dssp: $(OBJ)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
diff --git a/sci-chemistry/dssp/metadata.xml b/sci-chemistry/dssp/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/dssp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>