summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 08:21:32 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 08:21:32 +0000
commit7cde87c69ff266af037542bfa36f9c395ba2a0d9 (patch)
treefe4250eb2e2ae265b467dbd1061e7b0d9a643473 /sci-chemistry/molmol
parentStable on amd64 wrt bug #372889 (diff)
downloadgentoo-2-7cde87c69ff266af037542bfa36f9c395ba2a0d9.tar.gz
gentoo-2-7cde87c69ff266af037542bfa36f9c395ba2a0d9.tar.bz2
gentoo-2-7cde87c69ff266af037542bfa36f9c395ba2a0d9.zip
Straight out QA issues prior to stabilization
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molmol')
-rw-r--r--sci-chemistry/molmol/ChangeLog8
-rw-r--r--sci-chemistry/molmol/metadata.xml2
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2-r2.ebuild54
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2.ebuild39
4 files changed, 52 insertions, 51 deletions
diff --git a/sci-chemistry/molmol/ChangeLog b/sci-chemistry/molmol/ChangeLog
index fe87d721cced..c4337bb126d8 100644
--- a/sci-chemistry/molmol/ChangeLog
+++ b/sci-chemistry/molmol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/molmol
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.23 2010/11/08 17:14:25 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.24 2011/06/26 08:21:32 jlec Exp $
+
+ 26 Jun 2011; Justin Lecher <jlec@gentoo.org> molmol-2k_p2.ebuild,
+ molmol-2k_p2-r2.ebuild, metadata.xml:
+ Straight out QA issues prior to stabilization
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org> molmol-2k_p2.ebuild,
-molmol-2k_p2-r1.ebuild, molmol-2k_p2-r2.ebuild:
diff --git a/sci-chemistry/molmol/metadata.xml b/sci-chemistry/molmol/metadata.xml
index 9ac9ffdb3a41..e42d0af60f42 100644
--- a/sci-chemistry/molmol/metadata.xml
+++ b/sci-chemistry/molmol/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>
diff --git a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
index 033b8fc00d15..6b33fb05a078 100644
--- a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
+++ b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
@@ -1,38 +1,42 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.4 2010/11/08 17:14:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.5 2011/06/26 08:21:32 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit eutils toolchain-funcs multilib prefix
+inherit eutils multilib prefix toolchain-funcs
MY_PV="${PV/_p/.}.0"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Publication-quality molecular visualization package"
HOMEPAGE="http://hugin.ethz.ch/wuthrich/software/molmol/index.html"
-SRC_URI="ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
+SRC_URI="
+ ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-doc.tar.gz"
+
LICENSE="molmol"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
+
DEPEND="
media-libs/mesa[motif]
- virtual/jpeg
- media-libs/tiff
media-libs/libpng
+ media-libs/tiff
sys-libs/zlib
- x11-apps/xdpyinfo
+ virtual/jpeg
+ x11-libs/libXpm
>=x11-libs/openmotif-2.3:0
- x11-libs/libXpm"
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-# Yeah, the gz's aren't in a subdir.
+ x11-apps/xdpyinfo"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}"
MMDIR="/usr/$(get_libdir)/molmol"
+MAKEOPTS="${MAKEOPTS} -j1"
+
src_prepare() {
rm -rf tiff*
# Patch from http://pjf.net/science/molmol.html, where src.rpm is provided
@@ -45,35 +49,25 @@ src_prepare() {
ln -s makedef.lnx "${S}"/makedef
- # 1) The Korn shell is only taken by default because the Bourne shell
- # on DEC systems cannot handle the script.
- # We don't want this needless dependency.
- # 2) Fix up MOLMOLHOME, which determines the directory the binary's in.
- sed -i \
+ sed \
-e "s:/bin/ksh:${EPREFIX}/bin/sh:" \
-e "s:^MOLMOLHOME.*:MOLMOLHOME=${EPREFIX}/${MMDIR}:" \
- "${S}"/molmol
- # 1) Set CFLAGS.
- # 2) Set compiler.
- sed -i \
+ -i "${S}"/molmol || die
+ sed \
-e "s:^MCFLAGS.*:MCFLAGS = ${CFLAGS}:" \
-e "s:^CC.*:CC = $(tc-getCC):" \
- "${S}"/makedef
+ -i "${S}"/makedef || die
epatch "${FILESDIR}"/cast.patch
}
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
src_install() {
- dobin molmol || die
+ dobin molmol
exeinto ${MMDIR}
- newexe src/main/molmol molmol.lnx || die
+ newexe src/main/molmol molmol.lnx
insinto ${MMDIR}
- doins -r auxil help macros man setup tips || die
+ doins -r auxil help macros man setup tips
- dodoc HISTORY README || die
+ dodoc HISTORY README
}
diff --git a/sci-chemistry/molmol/molmol-2k_p2.ebuild b/sci-chemistry/molmol/molmol-2k_p2.ebuild
index 04c810b36ccc..e5d5a45f5636 100644
--- a/sci-chemistry/molmol/molmol-2k_p2.ebuild
+++ b/sci-chemistry/molmol/molmol-2k_p2.ebuild
@@ -1,41 +1,44 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2.ebuild,v 1.15 2010/11/08 17:14:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2.ebuild,v 1.16 2011/06/26 08:21:31 jlec Exp $
-EAPI="2"
+EAPI=2
-inherit eutils toolchain-funcs multilib
+inherit eutils multilib toolchain-funcs
MY_PV="${PV/_p/.}.0"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Publication-quality molecular visualization package"
HOMEPAGE="http://hugin.ethz.ch/wuthrich/software/molmol/index.html"
-SRC_URI="ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
+SRC_URI="
+ ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-doc.tar.gz"
+
LICENSE="molmol"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND=">=x11-libs/openmotif-2.3:0
- x11-libs/libXpm
+
+DEPEND="
media-libs/mesa[motif]
- virtual/jpeg
- media-libs/tiff
media-libs/libpng
- sys-libs/zlib"
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-# Yeah, the gz's aren't in a subdir.
-S=${WORKDIR}
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libXpm
+ >=x11-libs/openmotif-2.3:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
MMDIR="/usr/$(get_libdir)/molmol"
src_prepare() {
# Patch from http://pjf.net/science/molmol.html, where src.rpm is provided
- epatch ${FILESDIR}/pjf_RH9_molmol2k2.diff
+ epatch "${FILESDIR}"/pjf_RH9_molmol2k2.diff
- ln -s makedef.lnx ${S}/makedef
+ ln -s makedef.lnx "${S}"/makedef
# 1) The Korn shell is only taken by default because the Bourne shell
# on DEC systems cannot handle the script.
@@ -44,13 +47,13 @@ src_prepare() {
sed -i \
-e "s:/bin/ksh:/bin/sh:" \
-e "s:^MOLMOLHOME.*:MOLMOLHOME=${MMDIR}:" \
- ${S}/molmol
+ "${S}"/molmol
# 1) Set CFLAGS.
# 2) Set compiler.
sed -i \
-e "s:^MCFLAGS.*:MCFLAGS = ${CFLAGS}:" \
-e "s:^CC.*:CC = $(tc-getCC):" \
- ${S}/makedef
+ "${S}"/makedef
}
src_compile() {