summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-22 23:46:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-22 23:46:35 +0000
commit83e61f246129bc072c2f97d2fbc32604c9446e3c (patch)
tree99bc5630af0859be747cf6eb237a7b8a1b18fb54 /sci-chemistry/wxmacmolplt
parentLast rites for the rest of 1.4 JDK's. (diff)
downloadgentoo-2-83e61f246129bc072c2f97d2fbc32604c9446e3c.tar.gz
gentoo-2-83e61f246129bc072c2f97d2fbc32604c9446e3c.tar.bz2
gentoo-2-83e61f246129bc072c2f97d2fbc32604c9446e3c.zip
New revision does not install docs any more since they only consisted of the license file. This fixes also bug #300977.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog11
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild39
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
index e2da1bfbec35..c6dc9adb3375 100644
--- a/sci-chemistry/wxmacmolplt/ChangeLog
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/wxmacmolplt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.1 2009/11/01 14:34:22 alexxy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.2 2010/01/22 23:46:35 markusle Exp $
+
+*wxmacmolplt-7.3-r1 (22 Jan 2010)
+
+ 22 Jan 2010; Markus Dittrich <markusle@gentoo.org>
+ +wxmacmolplt-7.3-r1.ebuild:
+ New revision does not install docs any more since they only consisted
+ of the license file. This fixes also bug #300977.
*wxmacmolplt-7.3 (01 Nov 2009)
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild
new file mode 100644
index 000000000000..2e020c6cebf0
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild,v 1.1 2010/01/22 23:46:35 markusle Exp $
+
+EAPI="2"
+
+inherit base eutils autotools
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
+
+SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="flash"
+
+DEPEND="x11-libs/wxGTK[opengl]
+ flash? ( media-libs/ming )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "/^dist_doc_DATA/d" Makefile.am \
+ || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with flash ming)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png "Science;Education"
+}