summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-04 15:09:07 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-04 15:09:07 +0000
commitc974530130697c902d7229a2bffa5c44fccd7a58 (patch)
tree74482ac860e21a49cee98fb49bae3649e979aadb /sci-chemistry/xia2
parentRemove dependency on masked portage. All apis needed are in stable portage (diff)
downloadgentoo-2-c974530130697c902d7229a2bffa5c44fccd7a58.tar.gz
gentoo-2-c974530130697c902d7229a2bffa5c44fccd7a58.tar.bz2
gentoo-2-c974530130697c902d7229a2bffa5c44fccd7a58.zip
Version Bump
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/xia2')
-rw-r--r--sci-chemistry/xia2/ChangeLog8
-rw-r--r--sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch28
-rw-r--r--sci-chemistry/xia2/xia2-0.3.3.3.ebuild70
3 files changed, 105 insertions, 1 deletions
diff --git a/sci-chemistry/xia2/ChangeLog b/sci-chemistry/xia2/ChangeLog
index 1562455c6438..7216bb878cda 100644
--- a/sci-chemistry/xia2/ChangeLog
+++ b/sci-chemistry/xia2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/xia2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/ChangeLog,v 1.7 2011/07/23 13:17:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/ChangeLog,v 1.8 2011/10/04 15:09:07 jlec Exp $
+
+*xia2-0.3.3.3 (04 Oct 2011)
+
+ 04 Oct 2011; Justin Lecher <jlec@gentoo.org> +files/0.3.3.3-fix-syntax.patch,
+ +xia2-0.3.3.3.ebuild:
+ Version Bump
23 Jul 2011; Justin Lecher <jlec@gentoo.org> xia2-0.3.3.1.ebuild:
Added pstins msg
diff --git a/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch
new file mode 100644
index 000000000000..53cacbb5c681
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch
@@ -0,0 +1,28 @@
+diff --git a/xia2-0.3.3.0/Applications/xia2find.py b/xia2-0.3.3.0/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.3.3/Applications/xia2find.py
++++ b/xia2-0.3.3.3/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py b/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.3.3/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.3.3/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/xia2-0.3.3.3.ebuild b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
new file mode 100644
index 000000000000..333d5003aa57
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/xia2-0.3.3.3.ebuild,v 1.1 2011/10/04 15:09:07 jlec Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}/usr/share/ccp4/XIAROOT"
+ XIA2CORE_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2core-${PV}"
+ XIA2_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}"
+ PATH="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications"
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+ echo ""
+ elog "In order to use the package, you need to"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}