summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-03-25 19:58:15 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-03-25 19:58:15 +0000
commit06d26e9fe3920e93a3cfa4a97b58fc5a6da73fae (patch)
tree09d7f285c3a7b80afaf4a2fc1429c45deb16ac63 /sci-electronics/geda
parentppc stable wrt #291711 (diff)
downloadgentoo-2-06d26e9fe3920e93a3cfa4a97b58fc5a6da73fae.tar.gz
gentoo-2-06d26e9fe3920e93a3cfa4a97b58fc5a6da73fae.tar.bz2
gentoo-2-06d26e9fe3920e93a3cfa4a97b58fc5a6da73fae.zip
Drop old version.
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/geda')
-rw-r--r--sci-electronics/geda/ChangeLog6
-rw-r--r--sci-electronics/geda/files/geda-gattrib-1.4.0-gtkentry.patch109
-rw-r--r--sci-electronics/geda/geda-1.4.0-r1.ebuild115
3 files changed, 5 insertions, 225 deletions
diff --git a/sci-electronics/geda/ChangeLog b/sci-electronics/geda/ChangeLog
index ef161c4dead3..c738ad47d8c7 100644
--- a/sci-electronics/geda/ChangeLog
+++ b/sci-electronics/geda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/geda
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.67 2011/03/25 19:36:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.68 2011/03/25 19:58:15 tomjbe Exp $
+
+ 25 Mar 2011; Thomas Beierlein <tomjbe@gentoo.org> -geda-1.4.0-r1.ebuild,
+ -files/geda-gattrib-1.4.0-gtkentry.patch:
+ Drop old version.
25 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> geda-1.6.1.ebuild:
ppc stable wrt #285470
diff --git a/sci-electronics/geda/files/geda-gattrib-1.4.0-gtkentry.patch b/sci-electronics/geda/files/geda-gattrib-1.4.0-gtkentry.patch
deleted file mode 100644
index 10d023ef1030..000000000000
--- a/sci-electronics/geda/files/geda-gattrib-1.4.0-gtkentry.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-diff -ur -u geda-gattrib-1.4.3.orig/src/gtkitementry_2_2.c geda-gattrib-1.4.3/src/gtkitementry_2_2.c
---- geda-gattrib-1.4.3.orig/src/gtkitementry_2_2.c 2010-06-08 16:53:06.000000000 +0000
-+++ geda-gattrib-1.4.3/src/gtkitementry_2_2.c 2010-06-08 16:56:16.000000000 +0000
-@@ -811,23 +811,23 @@
- new_text_length = g_utf8_offset_to_pointer (new_text, n_chars) - new_text;
- }
-
-- if (new_text_length + entry->n_bytes + 1 > entry->text_size)
-+ if (new_text_length + entry->x_n_bytes + 1 > entry->x_text_size)
- {
-- while (new_text_length + entry->n_bytes + 1 > entry->text_size)
-+ while (new_text_length + entry->x_n_bytes + 1 > entry->x_text_size)
- {
-- if (entry->text_size == 0)
-- entry->text_size = MIN_SIZE;
-+ if (entry->x_text_size == 0)
-+ entry->x_text_size = MIN_SIZE;
- else
- {
-- if (2 * (guint)entry->text_size < MAX_SIZE &&
-- 2 * (guint)entry->text_size > entry->text_size)
-- entry->text_size *= 2;
-+ if (2 * (guint)entry->x_text_size < MAX_SIZE &&
-+ 2 * (guint)entry->x_text_size > entry->x_text_size)
-+ entry->x_text_size *= 2;
- else
- {
-- entry->text_size = MAX_SIZE;
-- if (new_text_length > (gint)entry->text_size - (gint)entry->n_bytes - 1)
-+ entry->x_text_size = MAX_SIZE;
-+ if (new_text_length > (gint)entry->x_text_size - (gint)entry->x_n_bytes - 1)
- {
-- new_text_length = (gint)entry->text_size - (gint)entry->n_bytes - 1;
-+ new_text_length = (gint)entry->x_text_size - (gint)entry->x_n_bytes - 1;
- new_text_length = g_utf8_find_prev_char (new_text, new_text + new_text_length + 1) - new_text;
- n_chars = g_utf8_strlen (new_text, new_text_length);
- }
-@@ -836,19 +836,19 @@
- }
- }
-
-- entry->text = g_realloc (entry->text, entry->text_size);
-+ entry->text = g_realloc (entry->text, entry->x_text_size);
- }
-
- index = g_utf8_offset_to_pointer (entry->text, *position) - entry->text;
-
-- g_memmove (entry->text + index + new_text_length, entry->text + index, entry->n_bytes - index);
-+ g_memmove (entry->text + index + new_text_length, entry->text + index, entry->x_n_bytes - index);
- memcpy (entry->text + index, new_text, new_text_length);
-
-- entry->n_bytes += new_text_length;
-+ entry->x_n_bytes += new_text_length;
- entry->text_length += n_chars;
-
- /* NUL terminate for safety and convenience */
-- entry->text[entry->n_bytes] = '\0';
-+ entry->text[entry->x_n_bytes] = '\0';
-
- if (entry->current_pos > *position)
- entry->current_pos += n_chars;
-@@ -881,9 +881,9 @@
- gint start_index = g_utf8_offset_to_pointer (entry->text, start_pos) - entry->text;
- gint end_index = g_utf8_offset_to_pointer (entry->text, end_pos) - entry->text;
-
-- g_memmove (entry->text + start_index, entry->text + end_index, entry->n_bytes + 1 - end_index);
-+ g_memmove (entry->text + start_index, entry->text + end_index, entry->x_n_bytes + 1 - end_index);
- entry->text_length -= (end_pos - start_pos);
-- entry->n_bytes -= (end_index - start_index);
-+ entry->x_n_bytes -= (end_index - start_index);
-
- if (entry->current_pos > start_pos)
- entry->current_pos -= MIN (entry->current_pos, end_pos) - start_pos;
-@@ -1157,7 +1157,7 @@
- {
- gtk_im_context_set_surrounding (context,
- entry->text,
-- entry->n_bytes,
-+ entry->x_n_bytes,
- g_utf8_offset_to_pointer (entry->text, entry->current_pos) - entry->text);
-
- return TRUE;
-@@ -1364,7 +1364,7 @@
-
- if (entry->visible)
- {
-- g_string_prepend_len (tmp_string, entry->text, entry->n_bytes);
-+ g_string_prepend_len (tmp_string, entry->text, entry->x_n_bytes);
- g_string_insert (tmp_string, cursor_index, preedit_string);
- }
- else
-@@ -1373,7 +1373,7 @@
- gint preedit_len_chars;
- gunichar invisible_char;
-
-- ch_len = g_utf8_strlen (entry->text, entry->n_bytes);
-+ ch_len = g_utf8_strlen (entry->text, entry->x_n_bytes);
- preedit_len_chars = g_utf8_strlen (preedit_string, -1);
- ch_len += preedit_len_chars;
-
-@@ -1407,7 +1407,7 @@
- {
- if (entry->visible)
- {
-- pango_layout_set_text (layout, entry->text, entry->n_bytes);
-+ pango_layout_set_text (layout, entry->text, entry->x_n_bytes);
- }
- else
- {
diff --git a/sci-electronics/geda/geda-1.4.0-r1.ebuild b/sci-electronics/geda/geda-1.4.0-r1.ebuild
deleted file mode 100644
index f1b6890018e4..000000000000
--- a/sci-electronics/geda/geda-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/geda-1.4.0-r1.ebuild,v 1.4 2011/03/02 18:06:07 jlec Exp $
-
-EAPI="1"
-
-inherit eutils versionator
-
-SUBDIR="v$(get_version_component_range 1-2)"
-S="${WORKDIR}"
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="Core metapackage for all the necessary components you would need for a minimal gEDA/gaf system"
-SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gattrib-${PV}.tar.gz
- http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gnetlist-${PV}.tar.gz
- http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gschem-${PV}.tar.gz
- http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gsymcheck-${PV}.tar.gz
- http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-symbols-${PV}.tar.gz
- http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-utils-${PV}.tar.gz
- doc? ( http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-docs-${PV}.tar.gz )
- examples? ( http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-examples-${PV}.tar.gz )"
-
-IUSE="doc examples gd threads"
-LICENSE="GPL-2"
-KEYWORDS="ppc"
-SLOT="0"
-
-DEPEND="
- x11-libs/gtk+:2
- >=dev-scheme/guile-1.6.3
- =sci-libs/libgeda-${PV}"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use sci-libs/libgeda gd || die "sci-libs/libgeda must be compiled with USE=gd"
- else
- ! built_with_use sci-libs/libgeda gd || die "sci-libs/libgeda must be compiled with USE=-gd"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # Fix security bug #247538 (CVE-2008-5148), thanks to Chitlesh Goorah
- sed -i \
- -e 's:TMP=/tmp/\$\$:TMP=$(mktemp):' \
- -e 's:>/tmp/\$\$:>${TMP}:' \
- "${S}"/geda-gnetlist-${PV}/scripts/sch2eaglepos.sh \
- || die "sed failed"
- # fix for renamed members of GTKEntry from gtk+-2.17 on (see bug 323127)
- cd "${S}"/geda-gattrib-${PV}
- epatch "${FILESDIR}"/geda-gattrib-${PV}-gtkentry.patch
-}
-
-src_compile() {
- local myconf="--disable-threads"
- use threads || myconf="--enable-threads=posix"
- for subdir in geda-{symbols,gschem,gnetlist,gsymcheck,gattrib,utils}-${PV}; do
- cd "${S}/${subdir}"
- econf \
- ${myconf} \
- --disable-dependency-tracking \
- --with-docdir=/usr/share/doc/${PF} \
- --with-pcbconfdir=/usr/share/pcb \
- --with-pcbm4dir=/usr/share/pcb/m4 \
- --disable-update-desktop-database \
- --disable-rpath \
- --with-x \
- || die "Configuration failed in ${subdir}"
- emake || die "Compilation failed in ${subdir}"
- done
-
- if use doc ; then
- cd "${S}/geda-docs-${PV}"
- econf --with-docdir=/usr/share/doc/${PF} || die "Configuration failed in geda-docs-${PV}"
- emake || die "Compilation failed in geda-docs-${PV}"
- fi
-}
-
-src_install () {
- for subdir in geda-{symbols,gschem,gnetlist,gsymcheck,gattrib,utils}-${PV}; do
- cd "${S}/${subdir}"
- emake DESTDIR="${D}" install || die "Installation failed in geda-${subdir}-${PV}"
- newdoc AUTHORS AUTHORS.${subdir}
- newdoc BUGS BUGS.${subdir}
- for READMEx in $(ls README*); do
- newdoc ${READMEx} ${READMEx}.${subdir}
- done
- done
-
- rm "${D}"/usr/share/gEDA/sym/gnetman -Rf # Fix collision with gnetman; bug #77361.
-
- if use doc ; then
- cd "${S}"/geda-docs-${PV}
- emake DESTDIR="${D}" install || die "Installation failed in geda-docs-${PV}"
- fi
-
- if use examples ; then
- cd "${S}"
- mv geda-examples-${PV} examples
- insinto /usr/share/gEDA
- doins -r examples
- fi
-}
-
-src_postinst() {
- fdo-mime_desktop_database_update
-}
-
-src_postrm() {
- fdo-mime_desktop_database_update
-}