summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2006-08-12 00:26:59 +0000
committerTim Yamin <plasmaroo@gentoo.org>2006-08-12 00:26:59 +0000
commit5ae7faeda47501b2d1b767b9566e3251a434ee82 (patch)
tree7191885354a13a82bac19887a04cc510a6b47065 /sci-electronics
parentdodoc: GENTOO does not exist (diff)
downloadgentoo-2-5ae7faeda47501b2d1b767b9566e3251a434ee82.tar.gz
gentoo-2-5ae7faeda47501b2d1b767b9566e3251a434ee82.tar.bz2
gentoo-2-5ae7faeda47501b2d1b767b9566e3251a434ee82.zip
Version bump; bug #141872.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gerbv/ChangeLog7
-rw-r--r--sci-electronics/gerbv/files/digest-gerbv-1.0.23
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.2.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/sci-electronics/gerbv/ChangeLog b/sci-electronics/gerbv/ChangeLog
index bcf20e36ce24..ba21919fd30d 100644
--- a/sci-electronics/gerbv/ChangeLog
+++ b/sci-electronics/gerbv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/gerbv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.15 2006/08/11 22:03:54 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.16 2006/08/12 00:26:59 plasmaroo Exp $
+
+*gerbv-1.0.2 (12 Aug 2006)
+
+ 12 Aug 2006; <plasmaroo@gentoo.org> +gerbv-1.0.2.ebuild:
+ Version bump; bug #141872.
11 Aug 2006; Jason Wever <weeve@gentoo.org> gerbv-1.0.1-r1.ebuild:
Added ~sparc keyword wrt bug #141421.
diff --git a/sci-electronics/gerbv/files/digest-gerbv-1.0.2 b/sci-electronics/gerbv/files/digest-gerbv-1.0.2
new file mode 100644
index 000000000000..c1a8e30e3a06
--- /dev/null
+++ b/sci-electronics/gerbv/files/digest-gerbv-1.0.2
@@ -0,0 +1,3 @@
+MD5 2d5dccd9a060e92916bb7a41ef5433e6 gerbv-1.0.2.tar.gz 1066247
+RMD160 f5d7e00fd9576f6ed8d0f1dee457fc9dd2c98c26 gerbv-1.0.2.tar.gz 1066247
+SHA256 87ec664cc5b161047d017f0ca9fbb5de9e428186f010c1f869ecd0a6384e0e7d gerbv-1.0.2.tar.gz 1066247
diff --git a/sci-electronics/gerbv/gerbv-1.0.2.ebuild b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
new file mode 100644
index 000000000000..92db6d6aace3
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.2.ebuild,v 1.1 2006/08/12 00:26:59 plasmaroo Exp $
+
+inherit eutils
+
+DESCRIPTION="gerbv - The gEDA Gerber Viewer"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.geda.seul.org"
+
+IUSE="doc png xinerama"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="=x11-libs/gtk+-2*
+ png? ( media-libs/libpng
+ media-libs/gdk-pixbuf )"
+
+src_compile() {
+ local confOptions
+
+ confOptions='--enable-gtk2'
+ use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use png || confOptions="$confOptions --disable-exportpng"
+
+ econf $confOptions || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ if use doc; then
+ cd doc
+ dodoc sources.txt
+ use png && dodoc PNG-print/PNGPrintMiniHowto.txt
+ docinto eagle
+ dodoc eagle/eagle2exc*
+ fi
+}