summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-12-30 17:02:44 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-12-30 17:02:44 +0000
commit75080e05bd4538ffccdce8273d6f4d293b37517d (patch)
treee391f2dd41e1707870c5feedf0e27ef83435289f /sci-libs/hdf5
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #448792 (diff)
downloadgentoo-2-75080e05bd4538ffccdce8273d6f4d293b37517d.tar.gz
gentoo-2-75080e05bd4538ffccdce8273d6f4d293b37517d.tar.bz2
gentoo-2-75080e05bd4538ffccdce8273d6f4d293b37517d.zip
Fix comments to prevent build failures on ia64 wrt #447740 by Agostino Sarubbo <ago@gentoo.org>
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog7
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.10-comments.patch42
-rw-r--r--sci-libs/hdf5/hdf5-1.8.10.ebuild5
3 files changed, 51 insertions, 3 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 527902a39b91..db03bb35a988 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.103 2012/12/30 15:07:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.104 2012/12/30 17:02:44 xarthisius Exp $
+
+ 30 Dec 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.10-comments.patch, hdf5-1.8.10.ebuild, hdf5-1.8.9-r2.ebuild:
+ Fix comments to prevent build failures on ia64 wrt #447740 by Agostino Sarubbo
+ <ago@gentoo.org>
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> hdf5-1.8.9-r2.ebuild:
Stable for alpha, wrt bug #440682
diff --git a/sci-libs/hdf5/files/hdf5-1.8.10-comments.patch b/sci-libs/hdf5/files/hdf5-1.8.10-comments.patch
new file mode 100644
index 000000000000..845bd81bdd8c
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.10-comments.patch
@@ -0,0 +1,42 @@
+Convert // comment marks to /**/ in order to fix FTBS on ia64
+
+https://bugs.gentoo.org/show_bug.cgi?id=447740
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/test/th5s.c
++++ b/test/th5s.c
+@@ -730,8 +730,8 @@ test_h5s_zero_dim(void)
+ ret = H5Pset_chunk(plist_id, SPACE1_RANK, chunk_dims);
+ CHECK(ret, FAIL, "H5Pset_chunk");
+
+- // ret = H5Pset_alloc_time(plist_id, alloc_time);
+- // CHECK(ret, FAIL, "H5Pset_alloc_time");
++ /* ret = H5Pset_alloc_time(plist_id, alloc_time);
++ CHECK(ret, FAIL, "H5Pset_alloc_time"); */
+
+ dset1 = H5Dcreate2(fid1, BASICDATASET1, H5T_NATIVE_INT, sid_chunk, H5P_DEFAULT, plist_id, H5P_DEFAULT);
+ CHECK(dset1, FAIL, "H5Dcreate2");
+--- a/tools/h5dump/h5dump_ddl.c
++++ b/tools/h5dump/h5dump_ddl.c
+@@ -1341,8 +1341,8 @@ handle_attributes(hid_t fid, const char *attr, void UNUSED * data, int UNUSED pe
+ string_dataformat.do_escape = display_escape;
+ outputformat = &string_dataformat;
+
+- //attr_name = attr + j + 1;
+- // need to replace escape characters
++ /* attr_name = attr + j + 1; */
++ /* need to replace escape characters */
+ attr_name = h5tools_str_replace(attr + j + 1, "\\/", "/");
+
+
+--- a/tools/lib/h5tools_str.c
++++ b/tools/lib/h5tools_str.c
+@@ -632,7 +632,7 @@ h5tools_str_indent(h5tools_str_t *str, const h5tool_format_t *info,
+ h5tools_str_append(str, "%s", OPT(info->line_indent, ""));
+ }
+
+-// ctx->need_prefix = 0;
++ /* ctx->need_prefix = 0; */
+ }
+
+ /*-------------------------------------------------------------------------
diff --git a/sci-libs/hdf5/hdf5-1.8.10.ebuild b/sci-libs/hdf5/hdf5-1.8.10.ebuild
index d5809e52e492..1f1136cecbe0 100644
--- a/sci-libs/hdf5/hdf5-1.8.10.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.10.ebuild,v 1.3 2012/12/11 17:31:05 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.10.ebuild,v 1.4 2012/12/30 17:02:44 xarthisius Exp $
EAPI=4
@@ -55,7 +55,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
"${FILESDIR}"/${P}-implicits.patch \
"${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch \
- "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch \
+ "${FILESDIR}"/${P}-comments.patch
# respect gentoo examples directory
sed \
-e "s:hdf5_examples:doc/${PF}/examples:g" \