summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-27 06:16:22 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-27 06:16:22 +0000
commit5069ccc8ed41c273c59ecd7a731ee63d4986043b (patch)
tree44e50bcf59bf3743c096fe493ad3400048f598af /sys-apps/busybox
parentadd ~amd64 keyword, reporter Andrew Savchenko (bug #252644) (diff)
downloadgentoo-2-5069ccc8ed41c273c59ecd7a731ee63d4986043b.tar.gz
gentoo-2-5069ccc8ed41c273c59ecd7a731ee63d4986043b.tar.bz2
gentoo-2-5069ccc8ed41c273c59ecd7a731ee63d4986043b.zip
Version bump.
(Portage version: 2.2_rc18/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog11
-rw-r--r--sys-apps/busybox/busybox-1.13.1.ebuild251
-rw-r--r--sys-apps/busybox/files/busybox-1.13.1-bindtodevice.patch86
-rw-r--r--sys-apps/busybox/files/busybox-1.13.1-crond.patch20
-rw-r--r--sys-apps/busybox/files/busybox-1.13.1-init.patch28
-rw-r--r--sys-apps/busybox/files/busybox-1.13.1-ip.patch11
-rw-r--r--sys-apps/busybox/files/busybox-1.13.1-printf.patch19
7 files changed, 425 insertions, 1 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 224be72fb7e4..cd51701398c3 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.208 2008/11/27 22:07:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.209 2008/12/27 06:16:22 vapier Exp $
+
+*busybox-1.13.1 (27 Dec 2008)
+
+ 27 Dec 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/busybox-1.13.1-bindtodevice.patch,
+ +files/busybox-1.13.1-crond.patch, +files/busybox-1.13.1-init.patch,
+ +files/busybox-1.13.1-ip.patch, +files/busybox-1.13.1-printf.patch,
+ +busybox-1.13.1.ebuild:
+ Version bump.
27 Nov 2008; Raúl Porcel <armin76@gentoo.org> busybox-1.11.3.ebuild:
alpha/arm/ia64/sparc/x86 stable
diff --git a/sys-apps/busybox/busybox-1.13.1.ebuild b/sys-apps/busybox/busybox-1.13.1.ebuild
new file mode 100644
index 000000000000..8b35669ac5d3
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.13.1.ebuild
@@ -0,0 +1,251 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.13.1.ebuild,v 1.1 2008/12/27 06:16:22 vapier Exp $
+
+inherit eutils flag-o-matic savedconfig toolchain-funcs
+
+################################################################################
+# BUSYBOX ALTERNATE CONFIG MINI-HOWTO
+#
+# Busybox can be modified in many different ways. Here's a few ways to do it:
+#
+# (1) Emerge busybox with FEATURES=keepwork so the work directory won't
+# get erased afterwards. Add a definition like ROOT=/my/root/path to the
+# start of the line if you're installing to somewhere else than the root
+# directory. This command will save the default configuration to
+# ${PORTAGE_CONFIGROOT} (or ${ROOT} if ${PORTAGE_CONFIGROOT} is not
+# defined), and it will tell you that it has done this. Note the location
+# where the config file was saved.
+#
+# FEATURES=keepwork USE=savedconfig emerge busybox
+#
+# (2) Go to the work directory and change the configuration of busybox using its
+# menuconfig feature.
+#
+# cd /var/tmp/portage/busybox*/work/busybox-*
+# make menuconfig
+#
+# (3) Save your configuration to the default location and copy it to the
+# one of the locations listed in /usr/portage/eclass/savedconfig.eclass
+#
+# (4) Emerge busybox with USE=savedconfig to use the configuration file you
+# just generated.
+#
+################################################################################
+#
+# (1) Alternatively skip the above steps and simply emerge busybox without
+# USE=savedconfig.
+#
+# (2) Edit the file it saves by hand. ${ROOT}"/etc/portage/savedconfig/${CATEGORY}/${PF}
+#
+# (3) Remerge busybox as using USE=savedconfig.
+#
+################################################################################
+
+#SNAPSHOT=20040726
+SNAPSHOT=""
+
+DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
+if [[ -n ${SNAPSHOT} ]] ; then
+ MY_P=${PN}
+ SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
+else
+ MY_P=${PN}-${PV/_/-}
+ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug make-symlinks pam selinux static"
+RESTRICT="test"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( sys-libs/pam )"
+
+S=${WORKDIR}/${MY_P}
+
+busybox_config_option() {
+ case $1 in
+ y) sed -i -e "s:.*CONFIG_$2.*set:CONFIG_$2=y:g" .config;;
+ n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
+ *) use $1 \
+ && busybox_config_option y $2 \
+ || busybox_config_option n $2
+ return 0
+ ;;
+ esac
+ einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
+}
+
+src_unpack() {
+ unset KBUILD_OUTPUT #88088
+
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+
+ # patches go here!
+ epatch "${FILESDIR}"/busybox-1.11.1-bb.patch
+ epatch "${FILESDIR}"/busybox-${PV}-*.patch
+
+ epatch "${FILESDIR}"/busybox-1.12.0-mdev-exec.patch
+
+ # work around broken ass powerpc compilers
+ use ppc64 && append-flags -mminimal-toc
+ # flag cleanup
+ sed -i -r \
+ -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
+ Makefile.flags || die
+ sed -i '/^#error Aborting compilation./d' applets/applets.c || die
+ use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
+ sed -i \
+ -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
+ -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ Makefile || die
+
+ # check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
+
+ restore_config .config
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ ewarn "Could not locate user configfile, so we will save a default one"
+ fi
+
+ # setup the config file
+ emake -j1 allyesconfig > /dev/null
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+ busybox_config_option n BUILD_AT_ONCE
+ busybox_config_option n BUILD_LIBBUSYBOX
+ busybox_config_option n NOMMU
+ busybox_config_option n MONOTONIC_SYSCALL
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y FEATURE_SH_IS_ASH
+ busybox_config_option n FEATURE_SH_IS_NONE
+
+ if use static && use pam ; then
+ ewarn "You cannot have USE='static pam'. Assuming static is more important."
+ fi
+ use static \
+ && busybox_config_option n PAM \
+ || busybox_config_option pam PAM
+ busybox_config_option static STATIC
+ busybox_config_option debug DEBUG
+ use debug \
+ && busybox_config_option y NO_DEBUG_LIB \
+ && busybox_config_option n DMALLOC \
+ && busybox_config_option n EFENCE
+
+ busybox_config_option selinux SELINUX
+
+ # default a bunch of uncommon options to off
+ local opt
+ for opt in \
+ APP_UDHCPD \
+ CRONTAB \
+ DC DPKG \
+ FAKEIDENTD FBSPLASH FOLD FTP{GET,PUT} \
+ HTTPD HUSH \
+ INETD INOTIFYD IPCALC \
+ LASH LOCALE_SUPPORT LOGNAME \
+ MSH \
+ OD \
+ SULOGIN \
+ TASKSET TFTP{,D} \
+ RPM RPM2CPIO \
+ UDPSVD UUDECODE UUENCODE
+ do
+ busybox_config_option n ${opt}
+ done
+
+ emake -j1 oldconfig > /dev/null
+}
+
+src_compile() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
+ emake busybox || die "build failed"
+ if ! use static && ! use pam ; then
+ mv busybox_unstripped{,.bak}
+ emake CONFIG_STATIC=y busybox || die "static build failed"
+ mv busybox_unstripped bb
+ mv busybox_unstripped{.bak,}
+ fi
+}
+
+src_install() {
+ unset KBUILD_OUTPUT #88088
+ save_config .config
+
+ into /
+ newbin busybox_unstripped busybox || die
+ if use static || use pam ; then
+ dosym busybox /bin/bb || die
+ dosym bb /bin/busybox.static || die
+ else
+ dobin bb || die
+ fi
+
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/mdev-start.sh || die
+
+ # bundle up the symlink files for use later
+ emake install || die
+ rm _install/bin/busybox
+ tar cf busybox-links.tar -C _install . || : #;die
+ insinto /usr/share/${PN}
+ doins busybox-links.tar || die
+ newins .config ${PF}.config || die
+
+ dodoc AUTHORS README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html *.sgml
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab depmod.pl *.conf *.script undeb unrpm
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ dodoc $(find . -type f)
+}
+
+pkg_preinst() {
+ if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
+
+ if use make-symlinks ; then
+ mv "${D}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use make-symlinks ; then
+ cd "${T}" || die
+ mkdir _install
+ tar xf busybox-links.tar -C _install || die
+ cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ fi
+
+ echo
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ echo
+}
diff --git a/sys-apps/busybox/files/busybox-1.13.1-bindtodevice.patch b/sys-apps/busybox/files/busybox-1.13.1-bindtodevice.patch
new file mode 100644
index 000000000000..1894145292c5
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.13.1-bindtodevice.patch
@@ -0,0 +1,86 @@
+--- busybox-1.13.1/include/libbb.h Sun Nov 9 18:28:17 2008
++++ busybox-1.13.1-bindtodevice/include/libbb.h Wed Dec 10 12:10:30 2008
+@@ -437,6 +437,7 @@
+ * Turn it on before you call bind(). */
+ void setsockopt_reuseaddr(int fd) FAST_FUNC; /* On Linux this never fails. */
+ int setsockopt_broadcast(int fd) FAST_FUNC;
++int setsockopt_bindtodevice(int fd, const char *iface) FAST_FUNC;
+ /* NB: returns port in host byte order */
+ unsigned bb_lookup_port(const char *port, const char *protocol, unsigned default_port) FAST_FUNC;
+ typedef struct len_and_sockaddr {
+--- busybox-1.13.1/libbb/xconnect.c Sun Nov 9 18:28:09 2008
++++ busybox-1.13.1-bindtodevice/libbb/xconnect.c Wed Dec 10 23:20:29 2008
+@@ -7,6 +7,7 @@
+ */
+
+ #include <netinet/in.h>
++#include <net/if.h>
+ #include "libbb.h"
+
+ void FAST_FUNC setsockopt_reuseaddr(int fd)
+@@ -17,6 +18,20 @@
+ {
+ return setsockopt(fd, SOL_SOCKET, SO_BROADCAST, &const_int_1, sizeof(const_int_1));
+ }
++int FAST_FUNC setsockopt_bindtodevice(int fd, const char *iface)
++{
++ int r;
++ struct ifreq ifr;
++ strncpy(ifr.ifr_name, iface, IFNAMSIZ);
++ /* Actually, ifr_name is at offset 0, and in practice
++ * just giving char[IFNAMSIZ] instead of struct ifreq works too.
++ * But just in case it's not true on some obscure arch... */
++ r = setsockopt(fd, SOL_SOCKET, SO_BINDTODEVICE, &ifr, sizeof(ifr));
++ if (r)
++ bb_perror_msg("can't bind to interface %s", iface);
++ return r;
++}
++
+
+ void FAST_FUNC xconnect(int s, const struct sockaddr *s_addr, socklen_t addrlen)
+ {
+--- busybox-1.13.1/networking/arping.c Sun Nov 9 18:27:59 2008
++++ busybox-1.13.1-bindtodevice/networking/arping.c Wed Dec 10 12:10:30 2008
+@@ -322,8 +322,7 @@
+ struct sockaddr_in saddr;
+ int probe_fd = xsocket(AF_INET, SOCK_DGRAM, 0);
+
+- if (setsockopt(probe_fd, SOL_SOCKET, SO_BINDTODEVICE, device, strlen(device) + 1) == -1)
+- bb_perror_msg("cannot bind to device %s", device);
++ setsockopt_bindtodevice(probe_fd, device);
+ memset(&saddr, 0, sizeof(saddr));
+ saddr.sin_family = AF_INET;
+ if (src.s_addr) {
+--- busybox-1.13.1/networking/ping.c Sun Nov 9 18:27:59 2008
++++ busybox-1.13.1-bindtodevice/networking/ping.c Wed Dec 10 12:10:30 2008
+@@ -572,7 +572,7 @@
+ xbind(pingsock, &source_lsa->u.sa, source_lsa->len);
+ }
+ if (str_I)
+- setsockopt(pingsock, SOL_SOCKET, SO_BINDTODEVICE, str_I, strlen(str_I) + 1);
++ setsockopt_bindtodevice(pingsock, str_I);
+
+ /* enable broadcast pings */
+ setsockopt_broadcast(pingsock);
+@@ -622,7 +622,7 @@
+ if (source_lsa)
+ xbind(pingsock, &source_lsa->u.sa, source_lsa->len);
+ if (str_I)
+- setsockopt(pingsock, SOL_SOCKET, SO_BINDTODEVICE, str_I, strlen(str_I) + 1);
++ setsockopt_bindtodevice(pingsock, str_I);
+
+ #ifdef ICMP6_FILTER
+ {
+--- busybox-1.13.1/networking/udhcp/socket.c Sun Nov 9 18:27:58 2008
++++ busybox-1.13.1-bindtodevice/networking/udhcp/socket.c Wed Dec 10 12:10:30 2008
+@@ -98,8 +98,8 @@
+ bb_perror_msg_and_die("SO_BROADCAST");
+
+ /* NB: bug 1032 says this doesn't work on ethernet aliases (ethN:M) */
+- if (setsockopt(fd, SOL_SOCKET, SO_BINDTODEVICE, &inf, strlen(inf) + 1) == -1)
+- bb_perror_msg_and_die("SO_BINDTODEVICE");
++ if (setsockopt_bindtodevice(fd, inf))
++ xfunc_die(); /* warning is already printed */
+
+ memset(&addr, 0, sizeof(addr));
+ addr.sin_family = AF_INET;
diff --git a/sys-apps/busybox/files/busybox-1.13.1-crond.patch b/sys-apps/busybox/files/busybox-1.13.1-crond.patch
new file mode 100644
index 000000000000..ca7e79c44b85
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.13.1-crond.patch
@@ -0,0 +1,20 @@
+--- busybox-1.13.1/miscutils/crond.c Sun Nov 9 18:28:17 2008
++++ busybox-1.13.1-crond/miscutils/crond.c Thu Dec 4 14:56:10 2008
+@@ -779,6 +779,8 @@
+ xmove_fd(mailFd, mail_filename ? 1 : 0);
+ dup2(1, 2);
+ }
++ /* crond 3.0pl1-100 puts tasks in separate process groups */
++ bb_setpgrp();
+ execlp(prog, prog, cmd, arg, NULL);
+ crondlog(ERR20 "can't exec, user %s cmd %s %s %s", user, prog, cmd, arg);
+ if (mail_filename) {
+@@ -914,6 +916,8 @@
+ if (DebugOpt) {
+ crondlog(LVL5 "child running %s", DEFAULT_SHELL);
+ }
++ /* crond 3.0pl1-100 puts tasks in separate process groups */
++ bb_setpgrp();
+ execl(DEFAULT_SHELL, DEFAULT_SHELL, "-c", line->cl_Shell, NULL);
+ crondlog(ERR20 "can't exec, user %s cmd %s %s %s", user,
+ DEFAULT_SHELL, "-c", line->cl_Shell);
diff --git a/sys-apps/busybox/files/busybox-1.13.1-init.patch b/sys-apps/busybox/files/busybox-1.13.1-init.patch
new file mode 100644
index 000000000000..23187720fc8e
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.13.1-init.patch
@@ -0,0 +1,28 @@
+--- busybox-1.13.1/init/init.c Sat Nov 29 07:48:56 2008
++++ busybox-1.13.1-init/init/init.c Tue Dec 9 22:17:43 2008
+@@ -118,18 +118,18 @@
+
+ msg[0] = '\r';
+ va_start(arguments, fmt);
+- l = vsnprintf(msg + 1, sizeof(msg) - 2, fmt, arguments);
+- if (l > sizeof(msg) - 2)
+- l = sizeof(msg) - 2;
++ l = 1 + vsnprintf(msg + 1, sizeof(msg) - 2, fmt, arguments);
++ if (l > sizeof(msg) - 1)
++ l = sizeof(msg) - 1;
+ msg[l] = '\0';
+ va_end(arguments);
+
+ if (ENABLE_FEATURE_INIT_SYSLOG) {
+- /* Log the message to syslogd */
+ if (where & L_LOG) {
+- /* don't print out "\r" */
+- openlog(applet_name, 0, LOG_DAEMON);
+- syslog(LOG_INFO, "init: %s", msg + 1);
++ /* Log the message to syslogd */
++ openlog("init", 0, LOG_DAEMON);
++ /* don't print "\r" */
++ syslog(LOG_INFO, "%s", msg + 1);
+ closelog();
+ }
+ msg[l++] = '\n';
diff --git a/sys-apps/busybox/files/busybox-1.13.1-ip.patch b/sys-apps/busybox/files/busybox-1.13.1-ip.patch
new file mode 100644
index 000000000000..50a9b270170a
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.13.1-ip.patch
@@ -0,0 +1,11 @@
+--- busybox-1.13.1/networking/ip.c Sun Nov 9 18:27:59 2008
++++ busybox-1.13.1-ip/networking/ip.c Thu Dec 4 13:16:29 2008
+@@ -31,7 +31,7 @@
+
+ static int ip_do(int (*ip_func)(char **argv), char **argv)
+ {
+- argv = ip_parse_common_args(argv);
++ argv = ip_parse_common_args(argv + 1);
+ return ip_func(argv);
+ }
+
diff --git a/sys-apps/busybox/files/busybox-1.13.1-printf.patch b/sys-apps/busybox/files/busybox-1.13.1-printf.patch
new file mode 100644
index 000000000000..43f4135b688c
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.13.1-printf.patch
@@ -0,0 +1,19 @@
+--- busybox-1.13.1/coreutils/printf.c Sun Nov 9 18:28:07 2008
++++ busybox-1.13.1-printf/coreutils/printf.c Wed Dec 10 12:50:55 2008
+@@ -359,8 +359,15 @@
+ * We will mimic coreutils. */
+ if (argv[1] && argv[1][0] == '-' && argv[1][1] == '-' && !argv[1][2])
+ argv++;
+- if (!argv[1])
++ if (!argv[1]) {
++ if (ENABLE_ASH_BUILTIN_PRINTF
++ && applet_name[0] != 'p'
++ ) {
++ bb_error_msg("usage: printf FORMAT [ARGUMENT...]");
++ return 2; /* bash compat */
++ }
+ bb_show_usage();
++ }
+
+ format = argv[1];
+ argv2 = argv + 2;