summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-21 15:22:28 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-21 15:22:28 +0000
commit55176c0298d5f01d5dc08c272dd6784c884806b8 (patch)
tree6a37ae616c3797875caf385d5ee02c878eeb82e4 /sys-apps/the_silver_searcher
parentCleanup obsolete masks (diff)
downloadgentoo-2-55176c0298d5f01d5dc08c272dd6784c884806b8.tar.gz
gentoo-2-55176c0298d5f01d5dc08c272dd6784c884806b8.tar.bz2
gentoo-2-55176c0298d5f01d5dc08c272dd6784c884806b8.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/the_silver_searcher')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog8
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.27.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index c344e1ad924e..d6f5c7ffc2d7 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.43 2014/10/28 00:36:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.44 2014/11/21 15:22:28 radhermit Exp $
+
+*the_silver_searcher-0.27.0 (21 Nov 2014)
+
+ 21 Nov 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.27.0.ebuild:
+ Version bump.
*the_silver_searcher-0.26.0 (28 Oct 2014)
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.27.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.27.0.ebuild
new file mode 100644
index 000000000000..9a4d44552352
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.27.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.27.0.ebuild,v 1.1 2014/11/21 15:22:28 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}