summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-07-19 20:50:27 +0000
committerHanno Böck <hanno@gentoo.org>2008-07-19 20:50:27 +0000
commit6bfba40de9a928c1e80de985bfd6b9c591d10e36 (patch)
tree170fea4a0b8e60c5c674a79b863ad51bb1816b07 /sys-auth/pam_mount
parentStable on amd64, bug #232337 (diff)
downloadgentoo-2-6bfba40de9a928c1e80de985bfd6b9c591d10e36.tar.gz
gentoo-2-6bfba40de9a928c1e80de985bfd6b9c591d10e36.tar.bz2
gentoo-2-6bfba40de9a928c1e80de985bfd6b9c591d10e36.zip
pam_moubt bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.26 i686)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.43.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 686dc444435e..d453181ad721 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.19 2008/06/17 17:06:50 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.20 2008/07/19 20:50:27 hanno Exp $
+
+*pam_mount-0.43 (19 Jul 2008)
+
+ 19 Jul 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.43.ebuild:
+ Version bump.
*pam_mount-0.41 (17 Jun 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.43.ebuild b/sys-auth/pam_mount/pam_mount-0.43.ebuild
new file mode 100644
index 000000000000..c10dbadbe42d
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.43.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.43.ebuild,v 1.1 2008/07/19 20:50:27 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}